summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-12-29 09:30:52 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-12-29 09:30:52 +0000
commit4b27be7854f48abe0efb2302d322d2e831036e0d (patch)
tree62fdfd2461f42d44bd4301df92dc15bc0069d7bd /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-4b27be7854f48abe0efb2302d322d2e831036e0d.tar.gz
gentoo-2-4b27be7854f48abe0efb2302d322d2e831036e0d.tar.bz2
gentoo-2-4b27be7854f48abe0efb2302d322d2e831036e0d.zip
Version bump, but still without smartcard support (libcacard is needed but doesn't build with our sys-apps/pcsc-lite thus only emulated smartcards would be available).
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog9
-rw-r--r--app-emulation/spice/spice-0.7.1.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index d1ce828b535a..d54b36f98bfc 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.4 2010/11/18 12:52:29 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.5 2010/12/29 09:30:52 dev-zero Exp $
+
+*spice-0.7.1 (29 Dec 2010)
+
+ 29 Dec 2010; Tiziano Müller <dev-zero@gentoo.org> +spice-0.7.1.ebuild:
+ Version bump, but still without smartcard support (libcacard is needed but
+ doesn't build with our sys-apps/pcsc-lite thus only emulated smartcards would
+ be available).
18 Nov 2010; Tiziano Müller <dev-zero@gentoo.org> spice-0.5.3.ebuild,
spice-0.6.3.ebuild:
diff --git a/app-emulation/spice/spice-0.7.1.ebuild b/app-emulation/spice/spice-0.7.1.ebuild
new file mode 100644
index 000000000000..a2f972fbf625
--- /dev/null
+++ b/app-emulation/spice/spice-0.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.1.ebuild,v 1.1 2010/12/29 09:30:52 dev-zero Exp $
+
+EAPI=3
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui static-libs"
+
+RDEPEND=">=app-emulation/spice-protocol-0.7.0
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ virtual/jpeg
+ sys-libs/zlib
+ gui? ( =dev-games/cegui-0.6* )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_configure() {
+ local myconf=""
+ use gui && myconf+="--enable-gui "
+ econf ${myconf} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}