summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-22 23:58:44 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-22 23:58:44 +0000
commit358a5f9d1521469eb7ac662522b1b686e413d37d (patch)
tree211b2300d98e33ef641adacceaec1b5e9a9def89 /app-emulation
parentDrop stale patches. (diff)
downloadgentoo-2-358a5f9d1521469eb7ac662522b1b686e413d37d.tar.gz
gentoo-2-358a5f9d1521469eb7ac662522b1b686e413d37d.tar.bz2
gentoo-2-358a5f9d1521469eb7ac662522b1b686e413d37d.zip
fix bug #291007 and install the ifup and ifdown scripts in the correct locations
(Portage version: 2.1.7.6/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog6
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild34
2 files changed, 11 insertions, 29 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 3db2231b4cbc..03855cbfe193 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.2 2009/11/22 23:31:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.3 2009/11/22 23:58:44 cardoe Exp $
+
+ 22 Nov 2009; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-0.11.0.ebuild:
+ fix bug #291007 and install the ifup and ifdown scripts in the correct
+ locations
22 Nov 2009; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-0.11.0.ebuild:
fix auto-magical depend against sasl
diff --git a/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild b/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild
index 34a64b89e5c3..cabd5009b098 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild,v 1.4 2009/11/22 23:49:48 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.11.0.ebuild,v 1.5 2009/11/22 23:58:44 cardoe Exp $
EAPI="2"
@@ -94,6 +94,8 @@ src_prepare() {
src_configure() {
local conf_opts audio_opts softmmu_targets user_targets
+ filter-flags -fpie -fstack-protector
+
for target in ${IUSE_SOFTMMU_TARGETS} ; do
use "qemu_softmmu_targets_${target}" && \
softmmu_targets="${softmmu_targets} ${target}-softmmu"
@@ -142,40 +144,16 @@ src_configure() {
|| die "configure failed"
}
-src_compile() {
- local mycc=$(cat config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
-
- filter-flags -fpie -fstack-protector
-
- # If using gentoo's compiler set the SPEC to non-hardened
- if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
- local myccver=$(${mycc} -dumpversion)
- local gccver=$($(tc-getBUILD_CC) -dumpversion)
-
- #Is this a SPEC for the right compiler version?
- myspec="${GCC_SPECS/${gccver}/${myccver}}"
- if [ "${myspec}" == "${GCC_SPECS}" ]; then
- shopt -s extglob
- GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
- shopt -u extglob
- else
- unset GCC_SPECS
- fi
- fi
-
- emake || die "emake failed"
-}
-
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
insinto /etc/udev/rules.d/
doins kvm/scripts/65-kvm.rules
- insinto /etc/kvm/
+ insinto /etc/qemu/
insopts -m0755
- newins kvm/scripts/qemu-ifup kvm-ifup
- newins kvm/scripts/qemu-ifdown kvm-ifdown
+ doins kvm/scripts/qemu-ifup
+ doins kvm/scripts/qemu-ifdown
dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
newdoc pc-bios/README README.pc-bios || die