summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-10 04:44:06 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-10 04:44:06 +0000
commit1a053a407d7337f16533c4bb76b948c008b09e73 (patch)
tree4a947dc79d764e96cd6316a867c31344d70033a1 /app-emulation
parentVersion bump (diff)
downloadgentoo-2-1a053a407d7337f16533c4bb76b948c008b09e73.tar.gz
gentoo-2-1a053a407d7337f16533c4bb76b948c008b09e73.tar.bz2
gentoo-2-1a053a407d7337f16533c4bb76b948c008b09e73.zip
Fix by Christophe LEFEBVRE for doc install #314661 by Diego E. Pettenò. Clean up the build system a bit #336092 by Diego E. Pettenò.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/coldfire/ChangeLog10
-rw-r--r--app-emulation/coldfire/coldfire-0.2.2.ebuild26
-rw-r--r--app-emulation/coldfire/coldfire-0.3.1.ebuild16
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-build.patch32
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-headers.patch16
5 files changed, 66 insertions, 34 deletions
diff --git a/app-emulation/coldfire/ChangeLog b/app-emulation/coldfire/ChangeLog
index 242f7a93e4ac..f0996f2acecd 100644
--- a/app-emulation/coldfire/ChangeLog
+++ b/app-emulation/coldfire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/coldfire
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/coldfire/ChangeLog,v 1.4 2007/02/21 21:41:22 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/coldfire/ChangeLog,v 1.5 2010/10/10 04:44:06 vapier Exp $
+
+ 10 Oct 2010; Mike Frysinger <vapier@gentoo.org> -coldfire-0.2.2.ebuild,
+ coldfire-0.3.1.ebuild, +files/coldfire-0.3.1-build.patch,
+ +files/coldfire-0.3.1-headers.patch:
+ Fix by Christophe LEFEBVRE for doc install #314661 by Diego E. Pettenò.
+ Clean up the build system a bit #336092 by Diego E. Pettenò.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-emulation/coldfire/coldfire-0.2.2.ebuild b/app-emulation/coldfire/coldfire-0.2.2.ebuild
deleted file mode 100644
index 0380a9533ebb..000000000000
--- a/app-emulation/coldfire/coldfire-0.2.2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/coldfire/coldfire-0.2.2.ebuild,v 1.3 2005/05/04 19:02:33 dholm Exp $
-
-DESCRIPTION="Motorola Coldfire Emulator"
-HOMEPAGE="http://www.slicer.ca/coldfire/"
-SRC_URI="http://www.slicer.ca/coldfire/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE=""
-
-DEPEND="sys-libs/ncurses
- sys-libs/readline"
-
-src_compile() {
- econf || die
- emake -j1 || die
-}
-
-src_install() {
- dodir /usr/bin
- einstall || die
- dodoc AUTHORS HACKING README
-}
diff --git a/app-emulation/coldfire/coldfire-0.3.1.ebuild b/app-emulation/coldfire/coldfire-0.3.1.ebuild
index fec14b2677f7..3a964c62ee58 100644
--- a/app-emulation/coldfire/coldfire-0.3.1.ebuild
+++ b/app-emulation/coldfire/coldfire-0.3.1.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/coldfire/coldfire-0.3.1.ebuild,v 1.1 2006/05/03 03:26:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/coldfire/coldfire-0.3.1.ebuild,v 1.2 2010/10/10 04:44:06 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
DESCRIPTION="Motorola Coldfire Emulator"
HOMEPAGE="http://www.slicer.ca/coldfire/"
@@ -14,13 +18,13 @@ IUSE=""
DEPEND="sys-libs/ncurses
sys-libs/readline"
-src_compile() {
- econf || die
- emake -j1 || die
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
}
src_install() {
dodir /usr/bin
einstall || die
- dodoc AUTHORS HACKING README
+ dodoc CONTRIBUTORS HACKING README
}
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-build.patch b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
new file mode 100644
index 000000000000..2b54dd4a16f5
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
@@ -0,0 +1,32 @@
+respect env build settings
+
+--- a/Makefile.rules.in
++++ b/Makefile.rules.in
+@@ -1,9 +1,9 @@
+ CC = @CC@
+-CFLAGS = -Wall -fomit-frame-pointer @CFLAGS@ -I$(TOPSRCDIR)
++CFLAGS = -Wall @CPPFLAGS@ @CFLAGS@ -I$(TOPSRCDIR)
+ LIBS = @LIBS@
+ LD_R = ld -r
+ RM = rm -f
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+
+ prefix = @prefix@
+
+fix parallel build problems ... objs need generated tracer, and coldfire
+needs subdir objs
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,7 +22,8 @@
+ #Force version to be made before subdirectories
+ subdirs-all: version.h
+
+-coldfire: $(OBJS) force
++$(OBJS): | subdirs-all
++coldfire: $(OBJS) force | subdirs-all
+ $(CC) $(LDFLAGS) $(OBJS) $(SUBDIR_OBJS) -o $@ $(LIBS)
+
+
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
new file mode 100644
index 000000000000..706b1a2b12c9
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
@@ -0,0 +1,16 @@
+make sure we have access to HAVE_* defines to include header files:
+
+run.c: In function ‘sigint’:
+run.c:51:2: warning: implicit declaration of function ‘readline’
+run.c:51:8: warning: cast to pointer from integer of different size
+
+--- a/run.c
++++ b/run.c
+@@ -7,6 +7,7 @@
+ /**********************************/
+
+
++#include "config.h"
+
+ #include <stdio.h>
+ #include <stdlib.h>