summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-08 04:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-08 04:36:47 +0000
commit98f1749565ac51472567dc080cadfbb244ff8c34 (patch)
treeee3190ce89bc8bf3aa584c17a0fa209f678f7062 /app-emulation/wine
parentremove old version. Add || die to make on -8 and do not install the license (diff)
downloadgentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.tar.gz
gentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.tar.bz2
gentoo-2-98f1749565ac51472567dc080cadfbb244ff8c34.zip
Add upstream patch for WMF exploit #118101 and make sure all ebuilds support modular X.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog11
-rw-r--r--app-emulation/wine/files/wine-wmf.patch24
-rw-r--r--app-emulation/wine/wine-0.9.1.ebuild21
-rw-r--r--app-emulation/wine/wine-0.9.2.ebuild21
-rw-r--r--app-emulation/wine/wine-0.9.3.ebuild3
-rw-r--r--app-emulation/wine/wine-0.9.4.ebuild3
-rw-r--r--app-emulation/wine/wine-0.9.5.ebuild3
-rw-r--r--app-emulation/wine/wine-0.9.ebuild21
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild20
-rw-r--r--app-emulation/wine/wine-20050111-r2.ebuild20
-rw-r--r--app-emulation/wine/wine-20050211.ebuild22
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild22
-rw-r--r--app-emulation/wine/wine-20050419.ebuild22
-rw-r--r--app-emulation/wine/wine-20050524.ebuild22
-rw-r--r--app-emulation/wine/wine-20050628.ebuild22
-rw-r--r--app-emulation/wine/wine-20050725-r1.ebuild20
-rw-r--r--app-emulation/wine/wine-20050830.ebuild22
-rw-r--r--app-emulation/wine/wine-20050930.ebuild4
18 files changed, 267 insertions, 36 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index e453d9302b4c..47a0626cc4cc 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.118 2006/01/05 23:39:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.119 2006/01/08 04:36:47 vapier Exp $
+
+ 08 Jan 2006; Mike Frysinger <vapier@gentoo.org> +files/wine-wmf.patch,
+ wine-0.9.ebuild, wine-0.9.1.ebuild, wine-0.9.2.ebuild, wine-0.9.3.ebuild,
+ wine-0.9.4.ebuild, wine-0.9.5.ebuild, wine-20041019-r3.ebuild,
+ wine-20050111-r2.ebuild, wine-20050211.ebuild, wine-20050310-r1.ebuild,
+ wine-20050419.ebuild, wine-20050524.ebuild, wine-20050628.ebuild,
+ wine-20050725-r1.ebuild, wine-20050830.ebuild, wine-20050930.ebuild:
+ Add upstream patch for WMF exploit #118101 and make sure all ebuilds support
+ modular X.
*wine-0.9.5 (05 Jan 2006)
diff --git a/app-emulation/wine/files/wine-wmf.patch b/app-emulation/wine/files/wine-wmf.patch
new file mode 100644
index 000000000000..3a993e24f4c7
--- /dev/null
+++ b/app-emulation/wine/files/wine-wmf.patch
@@ -0,0 +1,24 @@
+Upstream fix for WMF security issues.
+http://bugs.gentoo.org/118101
+
+===================================================================
+RCS file: /home/wine/wine/dlls/gdi/metafile.c,v
+retrieving revision 1.11
+retrieving revision 1.12
+diff -u -p -r1.11 -r1.12
+--- wine/dlls/gdi/metafile.c 2006/01/03 12:43:52 1.11
++++ wine/dlls/gdi/metafile.c 2006/01/06 20:52:46 1.12
+@@ -863,6 +863,13 @@ BOOL WINAPI PlayMetaFileRecord( HDC hdc,
+ break;
+
+ case META_ESCAPE:
++ switch (mr->rdParm[0]) {
++ case GETSCALINGFACTOR: /* get function ... would just NULL dereference */
++ return FALSE;
++ case SETABORTPROC:
++ FIXME("Filtering Escape(SETABORTPROC), possible virus?\n");
++ return FALSE;
++ }
+ Escape(hdc, mr->rdParm[0], mr->rdParm[1], (LPCSTR)&mr->rdParm[2], NULL);
+ break;
+
diff --git a/app-emulation/wine/wine-0.9.1.ebuild b/app-emulation/wine/wine-0.9.1.ebuild
index 4ed2c1870d95..c8611b04232d 100644
--- a/app-emulation/wine/wine-0.9.1.ebuild
+++ b/app-emulation/wine/wine-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.1.ebuild,v 1.2 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.1.ebuild,v 1.3 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
@@ -39,6 +47,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
@@ -64,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-0.9.2.ebuild b/app-emulation/wine/wine-0.9.2.ebuild
index cfae7d56dd8c..c0f0014b4923 100644
--- a/app-emulation/wine/wine-0.9.2.ebuild
+++ b/app-emulation/wine/wine-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.2.ebuild,v 1.2 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.2.ebuild,v 1.3 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
@@ -39,6 +47,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
@@ -64,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-0.9.3.ebuild b/app-emulation/wine/wine-0.9.3.ebuild
index 3fc7ebe649e4..8807a012e554 100644
--- a/app-emulation/wine/wine-0.9.3.ebuild
+++ b/app-emulation/wine/wine-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.3.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.3.ebuild,v 1.4 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-0.9.4.ebuild b/app-emulation/wine/wine-0.9.4.ebuild
index 4968f5ccf901..a34c74e86925 100644
--- a/app-emulation/wine/wine-0.9.4.ebuild
+++ b/app-emulation/wine/wine-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.4.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.4.ebuild,v 1.4 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-0.9.5.ebuild b/app-emulation/wine/wine-0.9.5.ebuild
index a903233dbbdc..6528d1cde9f8 100644
--- a/app-emulation/wine/wine-0.9.5.ebuild
+++ b/app-emulation/wine/wine-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.5.ebuild,v 1.1 2006/01/05 23:39:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.5.ebuild,v 1.2 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-0.9.ebuild b/app-emulation/wine/wine-0.9.ebuild
index aff5d28a7a52..1748f2b96805 100644
--- a/app-emulation/wine/wine-0.9.ebuild
+++ b/app-emulation/wine/wine-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.ebuild,v 1.2 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.ebuild,v 1.3 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
@@ -39,6 +47,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
@@ -64,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-wmf.patch
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index 572b06e8c413..6ad4ce59cf77 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.19 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.20 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -29,6 +37,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
glut? ( virtual/glut )
lcms? ( media-libs/lcms )"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
diff --git a/app-emulation/wine/wine-20050111-r2.ebuild b/app-emulation/wine/wine-20050111-r2.ebuild
index 59fc86a520e5..e3bcf3b6add6 100644
--- a/app-emulation/wine/wine-20050111-r2.ebuild
+++ b/app-emulation/wine/wine-20050111-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.4 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -29,6 +37,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
glut? ( virtual/glut )
lcms? ( media-libs/lcms )"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index c6876e0e6cf0..19b77a67d179 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.17 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.18 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 9d418023dcaa..97f4a981e140 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.10 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.11 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index 5b6486cc16b6..14a068c734e3 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.12 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.13 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index cb3a9e9769a2..e65e79018c6a 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.11 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.12 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses lcms" #doc
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
diff --git a/app-emulation/wine/wine-20050628.ebuild b/app-emulation/wine/wine-20050628.ebuild
index 76c834f52521..f9cc81b669a8 100644
--- a/app-emulation/wine/wine-20050628.ebuild
+++ b/app-emulation/wine/wine-20050628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.6 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.7 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses lcms" #doc
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
diff --git a/app-emulation/wine/wine-20050725-r1.ebuild b/app-emulation/wine/wine-20050725-r1.ebuild
index eb7192802a92..011385b03b06 100644
--- a/app-emulation/wine/wine-20050725-r1.ebuild
+++ b/app-emulation/wine/wine-20050725-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.4 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.5 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
diff --git a/app-emulation/wine/wine-20050830.ebuild b/app-emulation/wine/wine-20050830.ebuild
index b990b0ce185a..bb898b9bdf7f 100644
--- a/app-emulation/wine/wine-20050830.ebuild
+++ b/app-emulation/wine/wine-20050830.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.3 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.4 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses lcms" #doc
RESTRICT="test" #72375
@@ -18,7 +18,15 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
nas? ( media-libs/nas )
@@ -34,6 +42,14 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
sys-devel/bison
sys-devel/flex"
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
diff --git a/app-emulation/wine/wine-20050930.ebuild b/app-emulation/wine/wine-20050930.ebuild
index 60b68816e4f3..444efa8ea7e8 100644
--- a/app-emulation/wine/wine-20050930.ebuild
+++ b/app-emulation/wine/wine-20050930.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.7 2006/01/05 03:00:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.8 2006/01/08 04:36:47 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml2 X"
RESTRICT="test" #72375