summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-07-04 18:45:35 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-07-04 18:45:35 +0000
commit752f4d0aec029798ed6182e36cf51996b551dc58 (patch)
tree6485f5db5a1c7132e18e155e25b22aa03013c770 /app-emulation/wine
parentkpp fix (diff)
downloadgentoo-2-752f4d0aec029798ed6182e36cf51996b551dc58.tar.gz
gentoo-2-752f4d0aec029798ed6182e36cf51996b551dc58.tar.bz2
gentoo-2-752f4d0aec029798ed6182e36cf51996b551dc58.zip
kpp fix
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/Manifest5
-rw-r--r--app-emulation/wine/files/digest-wine-20030618-r15
-rw-r--r--app-emulation/wine/files/kpp-fix.patch29
-rw-r--r--app-emulation/wine/wine-20030618-r1.ebuild139
5 files changed, 184 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 5a1d776d4e8d..a43c52bc3769 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.45 2003/06/28 11:00:14 coronalvr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.46 2003/07/04 18:45:18 coronalvr Exp $
+
+*wine-20030618-r1 (04 Jul 2003)
+
+ 04 Jul 2003; Alex Veber <coronalvr@gentoo.org> wine-20030618-r1.ebuild,
+ files/kpp-fix.patch:
+ added a patch to fix a bug with kazaa kpp 2.1, thanks to cretin
+ (cretin@gentoo.org)
28 Jun 2003; Alex Veber <coronalvr@gentoo.org> wine-20030508.ebuild,
wine-20030618.ebuild:
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index b0ece2554bd7..3c01c59147bd 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,7 +1,8 @@
+MD5 03402d805ec87326fb636bd1bd29f03f wine-20030618.ebuild 3623
MD5 62de78f5d52d478759bd45a85b8c82b4 wine-20030508.ebuild 3510
MD5 cf7820d37da40ca549fdecbc8942ba50 wine-20030411-r1.ebuild 3312
-MD5 78e24d7734d2f62ebe9888a24fcf18cb ChangeLog 8902
-MD5 a4f827ee0646230385a8f190868424aa wine-20030618-r1.ebuild 3695
+MD5 00d9926df5aaae7aa09d6c3c4aceee3f ChangeLog 9121
+MD5 db55bb70ba0f0adcc57a4550af4924af wine-20030618-r1.ebuild 3698
MD5 dcd68f96e0066c424ec1ceb8411c7549 files/digest-wine-20030411-r1 67
MD5 bf24bbde88c8128df0743ebe3ee2aa43 files/digest-wine-20030618-r1 351
MD5 af8da46a0e51578ff1e18e399141d628 files/wine-20030411-fake_windows.tar.bz2 500
diff --git a/app-emulation/wine/files/digest-wine-20030618-r1 b/app-emulation/wine/files/digest-wine-20030618-r1
new file mode 100644
index 000000000000..2e5ef81457d0
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030618-r1
@@ -0,0 +1,5 @@
+MD5 71d1e24efd36dcd9522788e1dedb3c14 wine-20030618.tar.bz2 6976391
+MD5 bb9d5f77ffee8e72cf714aebc874157a wine-20030618-xopenfont.patch 1069
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20030618-fake_windows.tar.bz2 500
+MD5 8052677213b772973d85623012d68e86 wine-20030618-misc.tar.bz2 4591
+MD5 35f5ecf311952d369a24bdf7477c59df wine-nvidia-fix.patch.gz 6124
diff --git a/app-emulation/wine/files/kpp-fix.patch b/app-emulation/wine/files/kpp-fix.patch
new file mode 100644
index 000000000000..fe1a62a1a74a
--- /dev/null
+++ b/app-emulation/wine/files/kpp-fix.patch
@@ -0,0 +1,29 @@
+revision 1.95
+date: 2003/05/13 22:15:26; author: julliard; state: Exp; lines: +0 -2
+Dmitry Timoshkov <dmitry_at_codeweavers.com>
+Remove redundant ITypeLib2_AddRef's. Makes
+LoadTypeLib/ITypeLib2_Release work.
+Index: typelib.c
+===================================================================
+RCS file: /home/wine/wine/dlls/oleaut32/typelib.c,v
+retrieving revision 1.94
+retrieving revision 1.95
+diff -u -r1.94 -r1.95
+--- typelib.c 13 May 2003 00:41:58 -0000 1.94
++++ typelib.c 13 May 2003 22:15:26 -0000 1.95
+@@ -1844,7 +1844,6 @@
+ pcx->pTblDir->pTypeInfoTab.offset+count*sizeof(tiBase));
+ /* this is where we are coming from */
+ ptiRet->pTypeLib = pLibInfo;
+- ITypeLib2_AddRef((ITypeLib2 *)pLibInfo);
+ ptiRet->index=count;
+ /* fill in the typeattr fields */
+ FIXME("Assign constructor/destructor memid\n");
+@@ -3055,7 +3054,6 @@
+ }
+ *ppTypeInfoImpl = (ITypeInfoImpl*)ITypeInfo_Constructor();
+ (*ppTypeInfoImpl)->pTypeLib = pTypeLibImpl;
+- ITypeLib2_AddRef((ITypeLib2 *)pTypeLibImpl);
+ (*ppTypeInfoImpl)->index = i;
+ (*ppTypeInfoImpl)->Name = TLB_MultiByteToBSTR(
+ pOtherTypeInfoBlks[i].name_offs +
diff --git a/app-emulation/wine/wine-20030618-r1.ebuild b/app-emulation/wine/wine-20030618-r1.ebuild
new file mode 100644
index 000000000000..7448c3f54341
--- /dev/null
+++ b/app-emulation/wine/wine-20030618-r1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030618-r1.ebuild,v 1.1 2003/07/04 18:45:18 coronalvr Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+SRC_URI="mirror://gentoo/wine-${PV}.tar.bz2
+ mirror://gentoo/${P}-xopenfont.patch
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${P}-misc.tar.bz2
+ mirror://gentoo/wine-nvidia-fix.patch.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ epatch ${DISTDIR}/${P}-xopenfont.patch
+
+ cd ${S}/dlls/oleaut32/
+ patch -R < ${FILESDIR}/kpp-fix.patch
+
+ cd ${S}/dlls/opengl32
+ epatch ${WORKDIR}/wine-nvidia-fix.patch
+}
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="$myconf --enable-opengl" || myconf="$myconf --disable-opengl"
+ use nptl && myconf="$myconf --with-nptl" || myconf="$myconf --without-nptl"
+
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+}