summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-06-28 03:09:43 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-06-28 03:09:43 +0000
commitb2e0c5880a6f2c4b549f51ce1f7071a53894bd94 (patch)
treed285447bb2a663c2ddc4ac139ae877828558bb05 /app-emulation/virt-manager
parentSec patch applied, revbumped (diff)
downloadgentoo-2-b2e0c5880a6f2c4b549f51ce1f7071a53894bd94.tar.gz
gentoo-2-b2e0c5880a6f2c4b549f51ce1f7071a53894bd94.tar.bz2
gentoo-2-b2e0c5880a6f2c4b549f51ce1f7071a53894bd94.zip
VNC and SPICE aren't optional and are always imported so we can't make them optional.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/ChangeLog6
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0.ebuild15
2 files changed, 11 insertions, 10 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index a23c9f5414f4..77d611e71c21 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.84 2013/06/25 17:28:53 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.85 2013/06/28 03:09:43 cardoe Exp $
+
+ 28 Jun 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild:
+ VNC and SPICE aren't optional and are always imported so we can't make them
+ optional.
25 Jun 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild,
virt-manager-9999.ebuild:
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
index 54a53c7f66e4..f3230b895a79 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.4 2013/06/25 17:28:53 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.5 2013/06/28 03:09:43 cardoe Exp $
EAPI=5
@@ -26,7 +26,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="gnome-keyring policykit sasl +spice +vnc"
+IUSE="gnome-keyring policykit sasl"
RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
@@ -37,11 +37,11 @@ RDEPEND="!app-emulation/virtinst
dev-python/ipaddr[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/urlgrabber[${PYTHON_USEDEP}]
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}]
+ net-misc/spice-gtk[gtk3,introspection,python,sasl?]
x11-libs/vte:2.90[introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
- policykit? ( sys-auth/polkit )
- spice? ( net-misc/spice-gtk[gtk3,introspection,python,sasl?] )
- vnc? ( >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}] )"
+ policykit? ( sys-auth/polkit )"
DEPEND="${RDEPEND}
dev-lang/perl
dev-util/intltool"
@@ -56,12 +56,9 @@ python_prepare_all() {
distutils-r1_python_compile() {
local defgraphics=
- use vnc && defgraphics="vnc"
- use spice && defgraphics="spice"
-
esetup.py configure \
--qemu-user=qemu \
- --default-graphics=${defgraphics}
+ --default-graphics=spice
}
python_install_all() {