summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-30 03:24:33 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-30 03:24:33 +0000
commit9a1fc23f855b73816892ea86f4f63c909f238968 (patch)
treebbc3a64f03dce84b9e4eb2f6ca7d6c6b9fc40bcf /app-emulation/softgun/softgun-0.22.ebuild
parentadded ~arm (tested by me) (diff)
downloadgentoo-2-9a1fc23f855b73816892ea86f4f63c909f238968.tar.gz
gentoo-2-9a1fc23f855b73816892ea86f4f63c909f238968.tar.bz2
gentoo-2-9a1fc23f855b73816892ea86f4f63c909f238968.zip
Version bump #467870 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-emulation/softgun/softgun-0.22.ebuild')
-rw-r--r--app-emulation/softgun/softgun-0.22.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/softgun/softgun-0.22.ebuild b/app-emulation/softgun/softgun-0.22.ebuild
new file mode 100644
index 000000000000..210a81bd4387
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.22.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.22.ebuild,v 1.1 2013/04/30 03:24:33 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.22-make.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install prefix="${D}/usr"
+ dodoc README configs/*.sg
+}