summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-15 21:20:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-15 21:20:46 +0000
commit6562cda8e332ab91634a875e8fe62c848cfc7263 (patch)
tree5ddb00ac5bbf49f2a1325feed6575ed66c38ac14 /app-emulation/phpvirtualbox
parentMajor version bump zabbix 2.2.0, Minor ebuild cleanups, no keywords until tes... (diff)
downloadgentoo-2-6562cda8e332ab91634a875e8fe62c848cfc7263.tar.gz
gentoo-2-6562cda8e332ab91634a875e8fe62c848cfc7263.tar.bz2
gentoo-2-6562cda8e332ab91634a875e8fe62c848cfc7263.zip
Version bump. Bug #491296
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-emulation/phpvirtualbox')
-rw-r--r--app-emulation/phpvirtualbox/ChangeLog8
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/app-emulation/phpvirtualbox/ChangeLog b/app-emulation/phpvirtualbox/ChangeLog
index 1b28cb562578..ca621e1fcbd0 100644
--- a/app-emulation/phpvirtualbox/ChangeLog
+++ b/app-emulation/phpvirtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/phpvirtualbox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.11 2013/09/11 20:29:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.12 2013/11/15 21:20:46 hwoarang Exp $
+
+*phpvirtualbox-4.3.0 (15 Nov 2013)
+
+ 15 Nov 2013; Markos Chandras <hwoarang@gentoo.org>
+ +phpvirtualbox-4.3.0.ebuild:
+ Version bump. Bug #491296
*phpvirtualbox-4.2.7 (11 Sep 2013)
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild
new file mode 100644
index 000000000000..5ab4d8bb45b3
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild,v 1.1 2013/11/15 21:20:46 hwoarang Exp $
+
+EAPI="5"
+
+inherit versionator eutils webapp depend.php readme.gentoo
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+need_php_httpd
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+Local or remote virtualbox hosts must be compiled with
+'vboxwebsrv' useflag and the respective init script
+must be running to use this interface:
+/etc/init.d/vboxwebsrv start
+
+To enable the automatic startup mode feature uncomment the
+following line in the config.php file:
+var \$startStopConfig = true;
+
+You should also add the /etc/init.d/vboxinit script to the
+default runlevel on the virtualbox host:
+\`rc-update add vboxinit default\`
+If the server is on a remote host, than the script must be
+copied manually from
+'${FILESDIR}'/vboxinit-initd to
+/etc/init.d/vboxinit on the remote host."
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ readme.gentoo_print_elog
+}