summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-07 20:56:03 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-07 20:56:03 +0000
commite1d32a1f13363ed17c9bfd1d8c5d8d84b74534e1 (patch)
treeebcd9587895ad53c50add921ecee8c9619eb1893 /app-emulation/ganeti
parentMoved to EAPI=3 for PREFIX support, imported prefix patches from overlay, key... (diff)
downloadgentoo-2-e1d32a1f13363ed17c9bfd1d8c5d8d84b74534e1.tar.gz
gentoo-2-e1d32a1f13363ed17c9bfd1d8c5d8d84b74534e1.tar.bz2
gentoo-2-e1d32a1f13363ed17c9bfd1d8c5d8d84b74534e1.zip
Version bump, init script fix
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog12
-rw-r--r--app-emulation/ganeti/files/ganeti-2.1.initd4
-rw-r--r--app-emulation/ganeti/ganeti-2.1.0.ebuild74
3 files changed, 87 insertions, 3 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 758301a774d2..73a97b168739 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.17 2010/02/08 22:38:59 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.18 2010/03/07 20:56:03 ramereth Exp $
+
+*ganeti-2.1.0 (07 Mar 2010)
+
+ 07 Mar 2010; Lance Albertson <ramereth@gentoo.org> +ganeti-2.1.0.ebuild,
+ files/ganeti-2.1.initd:
+ Version bump, init script fix
+
+ Ganeti starts/stops drbd on its own and thus requiring the drbd init
+ script is
+ pointless so removing it.
08 Feb 2010; Lance Albertson <ramereth@gentoo.org>
ganeti-2.1.0_rc4.ebuild, files/ganeti-2.1.initd, +files/ganeti.confd:
diff --git a/app-emulation/ganeti/files/ganeti-2.1.initd b/app-emulation/ganeti/files/ganeti-2.1.initd
index 71c840212836..19f2ec5bdcbd 100644
--- a/app-emulation/ganeti/files/ganeti-2.1.initd
+++ b/app-emulation/ganeti/files/ganeti-2.1.initd
@@ -1,10 +1,10 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.2 2010/02/08 22:38:58 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.3 2010/03/07 20:56:02 ramereth Exp $
depend() {
- need localmount drbd
+ need localmount
after bootmisc
}
diff --git a/app-emulation/ganeti/ganeti-2.1.0.ebuild b/app-emulation/ganeti/ganeti-2.1.0.ebuild
new file mode 100644
index 000000000000..9aa8db147b71
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.1.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0.ebuild,v 1.1 2010/03/07 20:56:03 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+MY_PV="${PV/_rc/~rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/pyinotify
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-2.1.0_rc1-fix-brctl-path-for-gentoo.patch"
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ --with-file-storage-dir=/var/lib/ganeti-storage/file
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ newconfd "${FILESDIR}"/ganeti.confd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc INSTALL NEWS README doc/*.{rst,png}
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
+ docinto examples/hooks
+ dodoc doc/examples/hooks/{ipsec,ethers}
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}