summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:56:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:56:06 +0000
commit771cdc6e9deff81922e43e9671875f2394a924c4 (patch)
tree021bd3d46235d0904f2978a4c2130c0bd65d0015 /app-emulation/ganeti-htools
parentkwin-4.8 needs at least some opengl to build, bug 402029 (diff)
downloadgentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.tar.gz
gentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.tar.bz2
gentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.zip
Fixed USE=test to use QuickCheck-1.* (fixes bug #316629 by Diego Elio Pettenò and others). Added package to haskell herd as well.
(Portage version: 2.2.0_alpha89_p3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti-htools')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog10
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch14
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild10
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild10
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild10
-rw-r--r--app-emulation/ganeti-htools/metadata.xml1
6 files changed, 41 insertions, 14 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
index 0961fe300af3..6e4f161b94e0 100644
--- a/app-emulation/ganeti-htools/ChangeLog
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-htools
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.9 2011/03/12 19:11:19 ramereth Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.10 2012/03/07 17:56:06 slyfox Exp $
+
+ 07 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/ganeti-htools-0.2.8-use-QC-1.patch, ganeti-htools-0.2.8.ebuild,
+ ganeti-htools-0.3.0.ebuild, ganeti-htools-0.3.1.ebuild, metadata.xml:
+ Fixed USE=test to use QuickCheck-1.* (fixes bug #316629 by Diego Elio Pettenò
+ and others). Added package to haskell herd as well.
*ganeti-htools-0.3.1 (12 Mar 2011)
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch
new file mode 100644
index 000000000000..fd7943fe7057
--- /dev/null
+++ b/app-emulation/ganeti-htools/files/ganeti-htools-0.2.8-use-QC-1.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index 5e189fc..bfdf175 100644
+--- a/Makefile
++++ b/Makefile
+@@ -20,7 +20,8 @@ $(HALLPROGS): %: %.hs Ganeti/HTools/Version.hs $(HSRCS) Makefile
+
+ test live-test: HEXTRA=-fhpc -Wwarn -fno-warn-missing-signatures \
+ -fno-warn-monomorphism-restriction -fno-warn-orphans \
+- -fno-warn-missing-methods -fno-warn-unused-imports
++ -fno-warn-missing-methods -fno-warn-unused-imports \
++ -package $(shell ghc-pkg list | sed -n '/ QuickCheck-1./p')
+
+ $(DOCS) : %.html : %
+ rst2html -v --strict $< $@
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
index 792bc8b5a336..3fbf21065f05 100644
--- a/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild,v 1.3 2011/03/07 19:00:05 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild,v 1.4 2012/03/07 17:56:06 slyfox Exp $
EAPI="2"
-inherit multilib
+inherit eutils multilib
DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
clusters."
@@ -14,7 +14,7 @@ SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
+IUSE="doc test"
DEPEND="dev-lang/ghc
dev-haskell/json
@@ -22,11 +22,13 @@ DEPEND="dev-lang/ghc
dev-haskell/network"
RDEPEND="${DEPEND}
!>=app-emulation/ganeti-2.4"
+DEPEND+=" test? ( dev-haskell/quickcheck:1 )"
src_prepare() {
# htools does not currently compile cleanly with ghc-6.12+, so remove this
# for now
sed -i -e "s:-Werror ::" Makefile
+ epatch "${FILESDIR}"/${P}-use-QC-1.patch #316629
}
src_compile() {
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild
index 1842b0430b77..f3afc23a16d9 100644
--- a/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild,v 1.1 2011/02/10 20:54:09 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild,v 1.2 2012/03/07 17:56:06 slyfox Exp $
EAPI="2"
-inherit multilib
+inherit eutils multilib
DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
clusters."
@@ -14,7 +14,7 @@ SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
DEPEND="dev-lang/ghc
dev-haskell/json
@@ -23,6 +23,7 @@ DEPEND="dev-lang/ghc
dev-haskell/parallel"
RDEPEND="${DEPEND}
!<app-emulation/ganeti-2.4"
+DEPEND+=" test? ( dev-haskell/quickcheck:1 )"
src_prepare() {
# htools does not currently compile cleanly with ghc-6.12+, so remove this
@@ -30,6 +31,7 @@ src_prepare() {
sed -i -e "s:-Werror ::" Makefile
# Workaround to skip pandoc
sed -i -e "s:) man:):" Makefile
+ epatch "${FILESDIR}"/${PN}-0.2.8-use-QC-1.patch #316629
}
src_compile() {
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
index 819c0a998e9e..6d66164340ae 100644
--- a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild,v 1.1 2011/03/12 19:11:19 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild,v 1.2 2012/03/07 17:56:06 slyfox Exp $
EAPI="2"
-inherit multilib
+inherit eutils multilib
DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
clusters."
@@ -14,7 +14,7 @@ SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
DEPEND="dev-lang/ghc
dev-haskell/json
@@ -23,6 +23,7 @@ DEPEND="dev-lang/ghc
dev-haskell/parallel"
RDEPEND="${DEPEND}
!<app-emulation/ganeti-2.4"
+DEPEND+=" test? ( dev-haskell/quickcheck:1 )"
src_prepare() {
# htools does not currently compile cleanly with ghc-6.12+, so remove this
@@ -30,6 +31,7 @@ src_prepare() {
sed -i -e "s:-Werror ::" Makefile
# Workaround to skip pandoc
sed -i -e "s:) man:):" Makefile
+ epatch "${FILESDIR}"/${PN}-0.2.8-use-QC-1.patch #316629
}
src_compile() {
diff --git a/app-emulation/ganeti-htools/metadata.xml b/app-emulation/ganeti-htools/metadata.xml
index 1f2b3ed14d10..1f4a7724d89e 100644
--- a/app-emulation/ganeti-htools/metadata.xml
+++ b/app-emulation/ganeti-htools/metadata.xml
@@ -2,6 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>virtualization</herd>
+ <herd>haskell</herd>
<maintainer>
<email>ramereth@gentoo.org</email>
<name>Lance Albertson</name>