summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:52:39 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:52:39 +0000
commita0b6dbce56e8dce45fc3ea0e7f4efca95d0110ce (patch)
treee0f2b22e3b22db5481dfa2a9262d680df1eeb4ba /app-emulation/dgen-sdl
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-a0b6dbce56e8dce45fc3ea0e7f4efca95d0110ce.tar.gz
gentoo-2-a0b6dbce56e8dce45fc3ea0e7f4efca95d0110ce.tar.bz2
gentoo-2-a0b6dbce56e8dce45fc3ea0e7f4efca95d0110ce.zip
Changed econf||die to econf
Diffstat (limited to 'app-emulation/dgen-sdl')
-rw-r--r--app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild b/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
index 059f6cb0abba..05ab08ebc7d6 100644
--- a/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
+++ b/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.7 2002/11/17 22:33:11 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.8 2002/11/30 02:51:16 vapier Exp $
-IUSE="X mmx opengl"
-
-S=${WORKDIR}/${P}
DESCRIPTION="DGen/SDL is a Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://www.pknet.com/~joe/dgen-sdl.html"
SRC_URI="http://www.pknet.com/~joe/${P}.tar.gz"
@@ -12,20 +9,21 @@ SRC_URI="http://www.pknet.com/~joe/${P}.tar.gz"
SLOT="0"
KEYWORDS="x86"
LICENSE="dgen-sdl"
+IUSE="X mmx opengl"
+
DEPEND="media-libs/libsdl X? virtual/x11 opengl? virtual/opengl"
RDEPEND="${DEPEND} dev-lang/nasm"
src_compile() {
local myconf=""
-
use opengl || myconf="${myconf} --without-opengl"
use X && myconf="${myconf} --with-x"
use mmx || myconf="${myconf} --without-mmx"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}