summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2006-10-31 07:10:25 +0000
committerChristian Faulhammer <opfer@gentoo.org>2006-10-31 07:10:25 +0000
commitbac3d0b6f49efea9b30490cebd385424a5f424f6 (patch)
tree950d249944b1c2f19abb97f9dc50473af4018e36 /app-emacs
parentVersion bump. (diff)
downloadgentoo-2-bac3d0b6f49efea9b30490cebd385424a5f424f6.tar.gz
gentoo-2-bac3d0b6f49efea9b30490cebd385424a5f424f6.tar.bz2
gentoo-2-bac3d0b6f49efea9b30490cebd385424a5f424f6.zip
version bump, provided by Xavier Maillard <zedek@gnu.org> in bug #147990
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/u-vm-color/ChangeLog10
-rw-r--r--app-emacs/u-vm-color/files/51u-vm-color-gentoo.el8
-rw-r--r--app-emacs/u-vm-color/files/digest-u-vm-color-2.83
-rw-r--r--app-emacs/u-vm-color/u-vm-color-2.8.ebuild44
4 files changed, 63 insertions, 2 deletions
diff --git a/app-emacs/u-vm-color/ChangeLog b/app-emacs/u-vm-color/ChangeLog
index 20433d455e85..77b99698b5c7 100644
--- a/app-emacs/u-vm-color/ChangeLog
+++ b/app-emacs/u-vm-color/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/u-vm-color
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/u-vm-color/ChangeLog,v 1.7 2005/08/28 02:28:49 tester Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/u-vm-color/ChangeLog,v 1.8 2006/10/31 07:10:25 opfer Exp $
+
+*u-vm-color-2.8 (31 Oct 2006)
+
+ 31 Oct 2006; Christian Faulhammer <opfer@gentoo.org>
+ +files/51u-vm-color-gentoo.el, +u-vm-color-2.8.ebuild:
+ version bump, provided by Xavier Maillard <zedek@gnu.org> in bug #147990
28 Aug 2005; Olivier Crête <tester@gentoo.org> u-vm-color-1.7.ebuild:
Marked ~amd64, thanks to AT AJ Armstrong <aja@gentoo.org> for testing
diff --git a/app-emacs/u-vm-color/files/51u-vm-color-gentoo.el b/app-emacs/u-vm-color/files/51u-vm-color-gentoo.el
new file mode 100644
index 000000000000..2b273d92c2ed
--- /dev/null
+++ b/app-emacs/u-vm-color/files/51u-vm-color-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; u-vm-color site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'u-vm-color)
+(add-hook 'vm-summary-mode-hook 'u-vm-color-summary-mode)
+(add-hook 'vm-select-message-hook 'u-vm-color-fontify-buffer)
+
diff --git a/app-emacs/u-vm-color/files/digest-u-vm-color-2.8 b/app-emacs/u-vm-color/files/digest-u-vm-color-2.8
new file mode 100644
index 000000000000..4aa4010782ac
--- /dev/null
+++ b/app-emacs/u-vm-color/files/digest-u-vm-color-2.8
@@ -0,0 +1,3 @@
+MD5 55a7c54b0de0959550675c18016073a1 u-vm-color.el.txt 27160
+RMD160 f093bdd37e17a89515a6ab528ec0fe6dbdc931b0 u-vm-color.el.txt 27160
+SHA256 4dc2ffd34db3a1bf81c3f396bb9d27adfab85038ff6337dc1f0201c133e56d9d u-vm-color.el.txt 27160
diff --git a/app-emacs/u-vm-color/u-vm-color-2.8.ebuild b/app-emacs/u-vm-color/u-vm-color-2.8.ebuild
new file mode 100644
index 000000000000..af6a60f3a817
--- /dev/null
+++ b/app-emacs/u-vm-color/u-vm-color-2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/u-vm-color/u-vm-color-2.8.ebuild,v 1.1 2006/10/31 07:10:25 opfer Exp $
+
+inherit elisp
+
+DESCRIPTION="Color schemes for VM"
+HOMEPAGE="http://de.geocities.com/ulf_jasper/emacs.html#vm"
+SRC_URI="http://de.geocities.com/ulf_jasper/lisp/${PN}.el.txt"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/emacs
+ app-emacs/vm"
+
+SITEFILE=51u-vm-color-gentoo.el
+
+src_unpack() {
+ einfo "Copying file into ${S}..."
+
+ mkdir -p ${S}
+ cp ${DISTDIR}/${PN}.el.txt ${S}/${PN}.el || die
+}
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/${PN}.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}