summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 01:08:35 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 01:08:35 +0000
commit9f008645d4192f8a636aebdbc846d54fed501201 (patch)
treedb81c021a15c2b66a03ca4b1012230afbf827686 /app-emacs
parentVersion bump. (diff)
downloadgentoo-2-9f008645d4192f8a636aebdbc846d54fed501201.tar.gz
gentoo-2-9f008645d4192f8a636aebdbc846d54fed501201.tar.bz2
gentoo-2-9f008645d4192f8a636aebdbc846d54fed501201.zip
New snapshot from CVS. Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-w3m/ChangeLog10
-rw-r--r--app-emacs/emacs-w3m/emacs-w3m-1.4.379_pre20100125.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/app-emacs/emacs-w3m/ChangeLog b/app-emacs/emacs-w3m/ChangeLog
index 7a14b3df3516..def69cfb1284 100644
--- a/app-emacs/emacs-w3m/ChangeLog
+++ b/app-emacs/emacs-w3m/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/emacs-w3m
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/ChangeLog,v 1.66 2009/07/22 19:37:02 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/ChangeLog,v 1.67 2010/01/31 01:08:35 ulm Exp $
+
+*emacs-w3m-1.4.379_pre20100125 (30 Jan 2010)
+
+ 30 Jan 2010; Ulrich Mueller <ulm@gentoo.org>
+ +emacs-w3m-1.4.379_pre20100125.ebuild:
+ New snapshot from CVS. Add prefix keywords, change EAPI to 3.
22 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
-files/71emacs-w3m-gentoo.el, -emacs-w3m-1.4.4-r2.ebuild,
diff --git a/app-emacs/emacs-w3m/emacs-w3m-1.4.379_pre20100125.ebuild b/app-emacs/emacs-w3m/emacs-w3m-1.4.379_pre20100125.ebuild
new file mode 100644
index 000000000000..b18f6453a380
--- /dev/null
+++ b/app-emacs/emacs-w3m/emacs-w3m-1.4.379_pre20100125.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/emacs-w3m-1.4.379_pre20100125.ebuild,v 1.1 2010/01/31 01:08:35 ulm Exp $
+
+EAPI=3
+
+inherit elisp autotools
+
+DESCRIPTION="emacs-w3m is an interface program of w3m on Emacs"
+HOMEPAGE="http://emacs-w3m.namazu.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="linguas_ja"
+
+DEPEND="virtual/w3m"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ eautoreconf
+}
+
+# This is NOT redundant, elisp.eclass redefines src_configure
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake all-en $(useq linguas_ja && echo all-ja) || die "emake failed"
+}
+
+src_install() {
+ emake lispdir="${ED}${SITELISP}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ ICONDIR="${ED}${SITEETC}/${PN}" \
+ install-en $(useq linguas_ja && echo install-ja) install-icons \
+ || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README
+ use linguas_ja && dodoc BUGS.ja NEWS.ja README.ja
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${EPREFIX}/usr/share/doc/${PF}/README*"
+ einfo
+ elog "If you want to use the shimbun library, please emerge app-emacs/apel"
+ elog "and app-emacs/flim."
+ einfo
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}