summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-11-03 18:28:42 +0000
committerUlrich Müller <ulm@gentoo.org>2007-11-03 18:28:42 +0000
commit592192977c271cb6b08381e074a5b72f7d8cbbff (patch)
tree6958f3402265bd2431297330c9d33d511578dd8b /app-emacs
parentremoving =dev-lang/php-5.1* mask (related ebuilds are gone) (diff)
downloadgentoo-2-592192977c271cb6b08381e074a5b72f7d8cbbff.tar.gz
gentoo-2-592192977c271cb6b08381e074a5b72f7d8cbbff.tar.bz2
gentoo-2-592192977c271cb6b08381e074a5b72f7d8cbbff.zip
Inherit elisp instead of elisp-common; restore src_compile.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/imaxima/ChangeLog5
-rw-r--r--app-emacs/imaxima/imaxima-0.98.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/app-emacs/imaxima/ChangeLog b/app-emacs/imaxima/ChangeLog
index 4ee96ef1b289..dc9de5eed6b9 100644
--- a/app-emacs/imaxima/ChangeLog
+++ b/app-emacs/imaxima/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/imaxima
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.13 2007/11/03 18:08:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.14 2007/11/03 18:28:42 ulm Exp $
+
+ 03 Nov 2007; Ulrich Mueller <ulm@gentoo.org> imaxima-0.98.ebuild:
+ Inherit elisp instead of elisp-common; restore src_compile.
*imaxima-0.98 (03 Nov 2007)
diff --git a/app-emacs/imaxima/imaxima-0.98.ebuild b/app-emacs/imaxima/imaxima-0.98.ebuild
index 5234e229a2ba..86ab036b527a 100644
--- a/app-emacs/imaxima/imaxima-0.98.ebuild
+++ b/app-emacs/imaxima/imaxima-0.98.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/imaxima-0.98.ebuild,v 1.1 2007/11/03 18:08:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/imaxima-0.98.ebuild,v 1.2 2007/11/03 18:28:42 ulm Exp $
-inherit elisp-common
+inherit elisp
MY_P="${PN}-imath-${PV}"
DESCRIPTION="Imaxima enables graphical output in Maxima sessions with emacs"
@@ -22,9 +22,16 @@ DEPEND="virtual/tetex
SITEFILE=50${PN}-gentoo.el
S="${WORKDIR}/${MY_P}"
+# This is NOT redundant: elisp.eclass redefines src_compile() from default
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
dodoc ChangeLog NEWS README || die
docinto imath-example
dodoc imath-example/*.txt || die