summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/wl/wl-2.8.1.ebuild
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/wl/wl-2.8.1.ebuild')
-rw-r--r--app-emacs/wl/wl-2.8.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/wl/wl-2.8.1.ebuild b/app-emacs/wl/wl-2.8.1.ebuild
new file mode 100644
index 000000000000..72f37fb58e75
--- /dev/null
+++ b/app-emacs/wl/wl-2.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/wl-2.8.1.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Wanderlust is a mail/news reader supporting IMAP4rev1 for emacsen"
+HOMEPAGE="http://www.gohome.org/wl/index.html"
+SRC_URI="ftp://ftp.gohome.org/wl/stable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.3
+ >=app-emacs/flim-1.14.3
+ >=app-emacs/semi-1.14.3"
+# >=virtual/flim-1.14.3
+# >=virtual/semi-1.14.3
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ make || die;
+ make info || die;
+}
+
+src_install() {
+
+ make \
+ LISPDIR=${D}/usr/share/emacs/site-lisp \
+ PIXMAPDIR=${D}/usr/share/${PN}/icons \
+ install || die
+
+ elisp-site-file-install ${FILESDIR}/70wl-gentoo.el
+
+ dodir /usr/share/${PN}/samples
+
+ insinto /usr/share/${PN}/samples
+ doins samples/*
+
+ doinfo doc/wl-ja.info doc/wl.info
+ dodoc BUGS* COPYING ChangeLog INSTALL* README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P}/INSTALL.gz."
+ einfo "And Sample configuration files exist on /usr/share/${PN}/samples."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}