summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-03-17 18:01:35 +0000
committerUlrich Müller <ulm@gentoo.org>2014-03-17 18:01:35 +0000
commitccf72171375725bcd756f7452c645e05f690d4f4 (patch)
treeb9a936ca9876543fb6fb224f7c7b5dc61927cb32 /app-emacs/company-mode
parentAdd new freetype with harfbuzz dep to multilib mask. (diff)
downloadgentoo-2-ccf72171375725bcd756f7452c645e05f690d4f4.tar.gz
gentoo-2-ccf72171375725bcd756f7452c645e05f690d4f4.tar.bz2
gentoo-2-ccf72171375725bcd756f7452c645e05f690d4f4.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/ChangeLog7
-rw-r--r--app-emacs/company-mode/company-mode-0.7.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-emacs/company-mode/ChangeLog b/app-emacs/company-mode/ChangeLog
index 1c69c8bf7a27..6e32a19fe9c2 100644
--- a/app-emacs/company-mode/ChangeLog
+++ b/app-emacs/company-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/company-mode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.15 2014/03/17 00:02:10 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.16 2014/03/17 18:01:35 ulm Exp $
+
+*company-mode-0.7 (17 Mar 2014)
+
+ 17 Mar 2014; Ulrich Müller <ulm@gentoo.org> +company-mode-0.7.ebuild:
+ Version bump.
17 Mar 2014; Ulrich Müller <ulm@gentoo.org> -company-mode-0.6.11.ebuild,
company-mode-0.6.14.ebuild, metadata.xml:
diff --git a/app-emacs/company-mode/company-mode-0.7.ebuild b/app-emacs/company-mode/company-mode-0.7.ebuild
new file mode 100644
index 000000000000..4cff659285b8
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/company-mode-0.7.ebuild,v 1.1 2014/03/17 18:01:35 ulm Exp $
+
+EAPI=5
+NEED_EMACS=23
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://company-mode.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ropemacs"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="ropemacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}
+ ropemacs? ( dev-python/ropemacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_prepare() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+
+ elog "Removing pysmell backend"
+ rm company-pysmell.el || die
+
+ if ! use ropemacs; then
+ elog "Removing ropemacs backend, as requested by USE=-ropemacs"
+ rm company-ropemacs.el || die
+ fi
+}