summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-09-25 19:22:48 +0000
committerUlrich Müller <ulm@gentoo.org>2012-09-25 19:22:48 +0000
commit3eee035b4ca0604a155034a4c6f12213275b6463 (patch)
treebb0e6409a7516db223b392aef57f5049ad320e91 /app-emacs/bbdb
parentSpecify LICENSE more precisely, "as-is" is really HPND. (diff)
downloadgentoo-2-3eee035b4ca0604a155034a4c6f12213275b6463.tar.gz
gentoo-2-3eee035b4ca0604a155034a4c6f12213275b6463.tar.bz2
gentoo-2-3eee035b4ca0604a155034a4c6f12213275b6463.zip
Specify LICENSE more precisely. Bump ebuild to EAPI 4.
(Portage version: 2.1.11.20/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/bbdb')
-rw-r--r--app-emacs/bbdb/ChangeLog7
-rw-r--r--app-emacs/bbdb/bbdb-2.35-r1.ebuild23
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo.el3
3 files changed, 17 insertions, 16 deletions
diff --git a/app-emacs/bbdb/ChangeLog b/app-emacs/bbdb/ChangeLog
index 7b79e1a2b816..582bf5a1df95 100644
--- a/app-emacs/bbdb/ChangeLog
+++ b/app-emacs/bbdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/bbdb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.41 2009/11/24 20:48:13 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.42 2012/09/25 19:22:48 ulm Exp $
+
+ 25 Sep 2012; Ulrich Müller <ulm@gentoo.org> bbdb-2.35-r1.ebuild:
+ Specify LICENSE more precisely. Bump ebuild to EAPI 4.
24 Nov 2009; Christian Faulhammer <fauli@gentoo.org> bbdb-2.35-r1.ebuild:
import changes from Prefix overlay
diff --git a/app-emacs/bbdb/bbdb-2.35-r1.ebuild b/app-emacs/bbdb/bbdb-2.35-r1.ebuild
index 493af00eeaba..0a93dca01888 100644
--- a/app-emacs/bbdb/bbdb-2.35-r1.ebuild
+++ b/app-emacs/bbdb/bbdb-2.35-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.35-r1.ebuild,v 1.6 2009/11/24 20:48:13 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.35-r1.ebuild,v 1.7 2012/09/25 19:22:48 ulm Exp $
+
+EAPI=4
inherit elisp
@@ -10,30 +12,29 @@ SRC_URI="http://bbdb.sourceforge.net/${P}.tar.gz
http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
-LICENSE="GPL-2 as-is"
+LICENSE="GPL-2+ Texinfo-manual"
SLOT="0"
KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="tex"
-DEPEND=""
RDEPEND="tex? ( virtual/tex-base )"
-SITEFILE=50${PN}-gentoo.el
+SITEFILE="50${PN}-gentoo.el"
TEXMF="/usr/share/texmf-site"
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
-
+src_prepare() {
sed -i -e '0,/^--- bbdb-mail-folders.el ---$/d;/^--- end ---$/,$d' \
bits/bbdb-mail-folders.el || die "sed failed"
sed -i -e '/^;/,$!d' bits/bbdb-sort-mailrc.el || die "sed failed"
cp "${DISTDIR}"/{dates,point-at}.el bits || die "cp failed"
}
+src_configure() {
+ default
+}
+
src_compile() {
- econf || die "econf failed"
- emake -j1 || die "emake failed"
+ emake -j1
BYTECOMPFLAGS="-L bits -L lisp" elisp-compile bits/*.el || die
}
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo.el b/app-emacs/bbdb/files/50bbdb-gentoo.el
index 74771f82ad5d..7953b3c852a4 100644
--- a/app-emacs/bbdb/files/50bbdb-gentoo.el
+++ b/app-emacs/bbdb/files/50bbdb-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; bbdb site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(add-to-list 'load-path "@SITELISP@/bits")
(require 'bbdb)