summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-18 22:22:32 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-18 22:22:32 +0000
commitefe33691e27b77379f366e202226d8fa29358066 (patch)
tree413df66857927be175c6bde8091f6151b9b699c3 /app-editors
parentUSE=c++0x is gone from qt-webkit. (diff)
downloadgentoo-2-efe33691e27b77379f366e202226d8fa29358066.tar.gz
gentoo-2-efe33691e27b77379f366e202226d8fa29358066.tar.bz2
gentoo-2-efe33691e27b77379f366e202226d8fa29358066.zip
Add fix for kdebug 301808, incorrect working dir used
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kile/ChangeLog8
-rw-r--r--app-editors/kile/files/kile-2.1.2-cwd.patch89
-rw-r--r--app-editors/kile/kile-2.1.2-r1.ebuild62
3 files changed, 158 insertions, 1 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 854f1093d7c1..3ad37c95e657 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/kile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.155 2012/06/17 04:59:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.156 2012/06/18 22:22:32 dilfridge Exp $
+
+*kile-2.1.2-r1 (18 Jun 2012)
+
+ 18 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org> +kile-2.1.2-r1.ebuild,
+ +files/kile-2.1.2-cwd.patch:
+ Add fix for kdebug 301808, incorrect working dir used
17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> kile-2.1.2.ebuild:
Use global USE flag "postscript" instead of local USE flag "ps" for
diff --git a/app-editors/kile/files/kile-2.1.2-cwd.patch b/app-editors/kile/files/kile-2.1.2-cwd.patch
new file mode 100644
index 000000000000..cf09b56c7c5c
--- /dev/null
+++ b/app-editors/kile/files/kile-2.1.2-cwd.patch
@@ -0,0 +1,89 @@
+diff -ruN kile-2.1.2.orig/src/main.cpp kile-2.1.2/src/main.cpp
+--- kile-2.1.2.orig/src/main.cpp 2012-04-22 18:54:51.000000000 +0200
++++ kile-2.1.2/src/main.cpp 2012-06-19 00:10:46.096292174 +0200
+@@ -43,19 +43,19 @@
+ * Complete a relative paths to absolute ones.
+ * Also accepts URLs of the form file:relativepath.
+ */
+-QString completePath(const QString &path)
++QString completePath(const QString &path, const QString& currentPath)
+ {
+ QString fullpath(path);
+
+ KILE_DEBUG() << "==complete path is " << path;
+- if( QDir::isRelativePath(path) ) {
++ if(QDir::isRelativePath(path)) {
+ if(path.startsWith("file:")) {
+ KUrl url(path);
+- url.setFileName(completePath(url.toLocalFile()));
++ url.setFileName(completePath(url.toLocalFile(), currentPath));
+ fullpath = url.url();
+ }
+ else if(path.indexOf(QRegExp("^[a-z]+:")) == -1) {
+- fullpath = QDir::currentPath() + QDir::separator() + path;
++ fullpath = currentPath + QDir::separator() + path;
+ }
+ }
+
+@@ -138,6 +138,10 @@
+ KCmdLineArgs *args = KCmdLineArgs::parsedArgs();
+ bool running = false;
+
++ // we save the current path here to avoid problems when it's (erroneously) changed later
++ // (for instance, when a new KonsoleWidget is created, see #301808)
++ const QString currentPath = QDir::currentPath();
++
+ // this has to go before the DBus connection
+ KApplication app;
+
+@@ -151,13 +155,13 @@
+ for(int i = 0; i < args->count(); ++i) {
+ //FIXME: check whether this can be used to open Urls
+ if(isProject(args->arg(i))) {
+- kile->openProject(completePath(args->arg(i)));
++ kile->openProject(completePath(args->arg(i), currentPath));
+ }
+ else if(args->arg(i) == "-"){
+ kile->openDocument(readDataFromStdin());
+ }
+ else {
+- kile->openDocument(completePath(args->arg(i)));
++ kile->openDocument(completePath(args->arg(i), currentPath));
+ }
+ }
+
+@@ -175,16 +179,16 @@
+
+ for ( int i = 0; i < args->count(); ++i ) {
+ QString path = args->arg(i);
+- path = completePath(path);
++ path = completePath(path, currentPath);
+
+- if ( isProject(args->arg(i)) ){
+- interface->call("openProject",path);
++ if (isProject(args->arg(i))) {
++ interface->call("openProject", path);
+ }
+- else if(args->arg(i) == "-"){
+- interface->call("openDocument",readDataFromStdin());
++ else if(args->arg(i) == "-") {
++ interface->call("openDocument", readDataFromStdin());
+ }
+ else {
+- interface->call("openDocument",path);
++ interface->call("openDocument", path);
+ }
+ }
+
+diff -ruN kile-2.1.2.orig/src/widgets/konsolewidget.cpp kile-2.1.2/src/widgets/konsolewidget.cpp
+--- kile-2.1.2.orig/src/widgets/konsolewidget.cpp 2012-04-22 18:54:51.000000000 +0200
++++ kile-2.1.2/src/widgets/konsolewidget.cpp 2012-06-19 00:12:18.451297729 +0200
+@@ -78,8 +78,6 @@
+ layout()->addWidget(m_part->widget());
+ setFocusProxy(m_part->widget());
+ connect(m_part, SIGNAL(destroyed()), this, SLOT(slotDestroyed()));
+-
+- m_term->showShellInDir(QString());
+ }
+
+
diff --git a/app-editors/kile/kile-2.1.2-r1.ebuild b/app-editors/kile/kile-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..314215659c74
--- /dev/null
+++ b/app-editors/kile/kile-2.1.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.1.2-r1.ebuild,v 1.1 2012/06/18 22:22:32 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_DOC_DIRS="doc"
+ KDE_HANDBOOK="optional"
+ MY_P=${P/_beta/b}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+else
+ EGIT_REPO_URI="http://anongit.kde.org/kile"
+ GIT_ECLASS="git"
+fi
+
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="A Latex Editor and TeX shell for KDE"
+HOMEPAGE="http://kile.sourceforge.net/"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="debug +pdf +png"
+
+DEPEND="
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdebase-data)
+ || (
+ $(add_kdebase_dep okular 'pdf?,postscript')
+ app-text/acroread
+ )
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/dvipdfmx
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ media-gfx/imagemagick[png]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( kile-remote-control.txt )
+
+PATCHES=( "${FILESDIR}/${P}-cwd.patch" )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+
+ [[ ${PV} != *9999* ]] && { use handbook || rm -fr doc ; }
+}