summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-01 11:32:48 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-01 11:32:48 +0000
commitd245b093a5b018de254a0a3e7457302c15e88f17 (patch)
treef7dacb3b0ffd89b2cb06949dd50c4e0694918f30 /app-editors
parentOld. (diff)
downloadgentoo-2-d245b093a5b018de254a0a3e7457302c15e88f17.tar.gz
gentoo-2-d245b093a5b018de254a0a3e7457302c15e88f17.tar.bz2
gentoo-2-d245b093a5b018de254a0a3e7457302c15e88f17.zip
Backport the Python fixes from gnome overlay.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/ChangeLog5
-rw-r--r--app-editors/gedit/gedit-3.12.2-r1.ebuild57
2 files changed, 26 insertions, 36 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 9d877639554c..8440efd73b40 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.374 2014/11/24 10:06:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.375 2014/12/01 11:32:48 mgorny Exp $
+
+ 01 Dec 2014; Michał Górny <mgorny@gentoo.org> gedit-3.12.2-r1.ebuild:
+ Backport the Python fixes from gnome overlay.
24 Nov 2014; Pacho Ramos <pacho@gentoo.org> gedit-3.12.2-r1.ebuild:
Support python 3.4
diff --git a/app-editors/gedit/gedit-3.12.2-r1.ebuild b/app-editors/gedit/gedit-3.12.2-r1.ebuild
index 1ab5756b9353..58d11027c17d 100644
--- a/app-editors/gedit/gedit-3.12.2-r1.ebuild
+++ b/app-editors/gedit/gedit-3.12.2-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.12.2-r1.ebuild,v 1.2 2014/11/24 10:06:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.12.2-r1.ebuild,v 1.3 2014/12/01 11:32:48 mgorny Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{2,3,4} )
+PYTHON_COMPAT=( python3_{3,4} )
inherit eutils gnome2 multilib python-r1 virtualx
@@ -16,7 +16,9 @@ LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
IUSE="+introspection +python spell zeitgeist"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+# we need to fix that
+REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
@@ -42,7 +44,8 @@ COMMON_DEPEND="
>=x11-libs/gtk+-3:3[introspection]
>=x11-libs/gtksourceview-3.6:3.0[introspection]
dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}] )
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[${PYTHON_USEDEP}] )
spell? (
>=app-text/enchant-1.2:=
>=app-text/iso-codes-0.35 )
@@ -50,7 +53,6 @@ COMMON_DEPEND="
"
RDEPEND="${COMMON_DEPEND}
x11-themes/gnome-icon-theme-symbolic
- python? ( dev-libs/libpeas[${PYTHON_USEDEP}] )
"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
@@ -63,6 +65,10 @@ DEPEND="${COMMON_DEPEND}
"
# yelp-tools, gnome-common needed to eautoreconf
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
src_prepare() {
# FIXME: Not able to set some metadata
sed -e '/g_test_add_func/d' \
@@ -74,27 +80,15 @@ src_prepare() {
src_configure() {
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- gedit_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-deprecations \
- --enable-updater \
- --enable-gvfs-metadata \
- $(use_enable introspection) \
- $(use_enable spell) \
- $(use_enable zeitgeist) \
- ITSTOOL=$(type -P true) \
- "$@"
- }
-
- gedit_py_configure() {
- mkdir -p "${BUILD_DIR}" || die
- run_in_build_dir gedit_configure --enable-python
- }
-
- # run gedit_py_configure first to avoid out-of-source build for C code
- use python && python_parallel_foreach_impl gedit_py_configure
- gedit_configure --disable-python
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-updater \
+ --enable-gvfs-metadata \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable python) \
+ $(use_enable zeitgeist) \
+ ITSTOOL=$(type -P true)
}
src_test() {
@@ -106,13 +100,6 @@ src_test() {
}
src_install() {
- gedit_py_install() {
- pushd "${BUILD_DIR}" > /dev/null || die
- # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
- emake DESTDIR="${D}" top_builddir="${S}" pyoverridesdir="$(python_get_sitedir)/gi/overrides" install
- popd > /dev/null
- }
-
- gnome2_src_install
- use python && python_foreach_impl gedit_py_install
+ # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
+ gnome2_src_install pyoverridesdir="$(python_get_sitedir)/gi/overrides"
}