summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-09-24 13:00:13 +0000
committerUlrich Müller <ulm@gentoo.org>2011-09-24 13:00:13 +0000
commita1d838fe86aab4140be745108d87b95fa5372072 (patch)
tree031030be608861c9906410ea5eb0cba0b4d05bae /app-editors
parentPatch suggested by both Ryan Hill & Pacho Ramos allows building on GCC 4.6; c... (diff)
downloadgentoo-2-a1d838fe86aab4140be745108d87b95fa5372072.tar.gz
gentoo-2-a1d838fe86aab4140be745108d87b95fa5372072.tar.bz2
gentoo-2-a1d838fe86aab4140be745108d87b95fa5372072.zip
Link against libXaw with USE=athena. Change [ ] to [[ ]] throughout.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-23.3-r2.ebuild23
-rw-r--r--app-editors/emacs/metadata.xml2
3 files changed, 20 insertions, 11 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 49e59b043f8b..c5c56893ccbf 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.429 2011/09/08 14:10:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.430 2011/09/24 13:00:13 ulm Exp $
+
+ 24 Sep 2011; Ulrich Mueller <ulm@gentoo.org> emacs-23.3-r2.ebuild,
+ metadata.xml:
+ Link against libXaw with USE=athena. Change [ ] to [[ ]] throughout.
02 Sep 2011; Ulrich Mueller <ulm@gentoo.org> emacs-23.3-r2.ebuild:
Backport some changes from the emacs-vcs live ebuild.
diff --git a/app-editors/emacs/emacs-23.3-r2.ebuild b/app-editors/emacs/emacs-23.3-r2.ebuild
index 42ff73125825..76a46adc3c11 100644
--- a/app-editors/emacs/emacs-23.3-r2.ebuild
+++ b/app-editors/emacs/emacs-23.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r2.ebuild,v 1.3 2011/09/08 14:10:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r2.ebuild,v 1.4 2011/09/24 13:00:13 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.bz2
LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode PSF-2"
SLOT="23"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="alsa aqua dbus gconf gif gpm gtk gzip-el hesiod jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+IUSE="alsa aqua athena dbus gconf gif gpm gtk gzip-el hesiod jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
REQUIRED_USE="aqua? ( !X )"
RDEPEND="sys-libs/ncurses
@@ -49,7 +49,10 @@ RDEPEND="sys-libs/ncurses
gtk? ( x11-libs/gtk+:2 )
!gtk? (
Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( motif? ( >=x11-libs/openmotif-2.3:0 ) )
+ !Xaw3d? (
+ athena? ( x11-libs/libXaw )
+ !athena? ( motif? ( >=x11-libs/openmotif-2.3:0 ) )
+ )
)
)"
@@ -145,9 +148,9 @@ src_configure() {
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf="${myconf} --with-x-toolkit=gtk"
- elif use Xaw3d; then
- einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
- myconf="${myconf} --with-x-toolkit=lucid"
+ elif use Xaw3d || use athena; then
+ einfo "Configuring to build with Athena/Lucid toolkit"
+ myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"
@@ -157,9 +160,9 @@ src_configure() {
fi
local f tk=
- for f in gtk Xaw3d motif; do
+ for f in gtk Xaw3d athena motif; do
use ${f} || continue
- [ "${tk}" ] \
+ [[ ${tk} ]] \
&& ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
tk="${tk}${tk:+ }${f}"
done
@@ -268,7 +271,7 @@ src_install () {
pkg_preinst() {
# move Info dir file to correct name
local infodir=/usr/share/info/${EMACS_SUFFIX} f
- if [ -f "${ED}"${infodir}/dir.orig ]; then
+ if [[ -f ${ED}${infodir}/dir.orig ]]; then
mv "${ED}"${infodir}/dir{.orig,} || die "moving info dir failed"
else
# this should not happen in EAPI 4
@@ -286,7 +289,7 @@ pkg_preinst() {
pkg_postinst() {
local f
for f in "${EROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
- [ -e "${f}" ] || touch "${f}"
+ [[ -e ${f} ]] || touch "${f}"
done
chown "${GAMES_USER_DED:-games}" "${EROOT}"/var/lib/games/emacs
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
index adb9915f4e11..84f3ac6149d3 100644
--- a/app-editors/emacs/metadata.xml
+++ b/app-editors/emacs/metadata.xml
@@ -20,6 +20,8 @@
available separately.
</longdescription>
<use>
+ <flag name='athena'>Enable the MIT Athena widget set
+ (<pkg>x11-libs/libXaw</pkg>)</flag>
<flag name='gconf'>Use <pkg>gnome-base/gconf</pkg> to read the system
font name</flag>
<flag name='gzip-el'>Compress bundled Emacs Lisp source</flag>