summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-02-10 17:53:39 +0000
committerFabian Groffen <grobian@gentoo.org>2012-02-10 17:53:39 +0000
commit1bc146879882800fa260b4bfd6818bfd74caec85 (patch)
tree3695d02fd9cb855c2a1ad1e5c9b8b288d46f736a /app-editors
parentAdd new video_cards_* to use.mask. (diff)
downloadgentoo-2-1bc146879882800fa260b4bfd6818bfd74caec85.tar.gz
gentoo-2-1bc146879882800fa260b4bfd6818bfd74caec85.tar.bz2
gentoo-2-1bc146879882800fa260b4bfd6818bfd74caec85.zip
Fixed for Prefix, transferred Prefix keywords
(Portage version: 2.2.01.20153-prefix/cvs/Darwin i386)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/joe/ChangeLog8
-rw-r--r--app-editors/joe/files/joe-3.7-sanitise-includes.patch36
-rw-r--r--app-editors/joe/joe-3.7-r1.ebuild17
3 files changed, 50 insertions, 11 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 2f3ae09abfa4..65f1972b4bce 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/joe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.75 2010/10/19 06:25:19 leio Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.76 2012/02/10 17:53:39 grobian Exp $
+
+ 10 Feb 2012; Fabian Groffen <grobian@gentoo.org>
+ +files/joe-3.7-sanitise-includes.patch, joe-3.7-r1.ebuild:
+ Fixed for Prefix, transferred Prefix keywords
19 Oct 2010; Mart Raudsepp <leio@gentoo.org> joe-3.5.ebuild:
Drop to ~mips
diff --git a/app-editors/joe/files/joe-3.7-sanitise-includes.patch b/app-editors/joe/files/joe-3.7-sanitise-includes.patch
new file mode 100644
index 000000000000..0d60cdb41e18
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-sanitise-includes.patch
@@ -0,0 +1,36 @@
+injecting random paths breaks random on Prefix platforms
+
+--- configure.ac
++++ configure.ac
+@@ -23,14 +23,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+
+-case "$host" in
+- *-*-solaris*)
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib"
+- ;;
+- *) ;;
+-esac
+-
+ search_libs="$search_libs m"
+
+ # Checks for libraries.
+--- configure
++++ configure
+@@ -4071,14 +4071,6 @@
+ fi
+
+
+-case "$host" in
+- *-*-solaris*)
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib"
+- ;;
+- *) ;;
+-esac
+-
+ search_libs="$search_libs m"
+
+ # Checks for libraries.
diff --git a/app-editors/joe/joe-3.7-r1.ebuild b/app-editors/joe/joe-3.7-r1.ebuild
index 75a0180fe4ac..a1a6a06db685 100644
--- a/app-editors/joe/joe-3.7-r1.ebuild
+++ b/app-editors/joe/joe-3.7-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7-r1.ebuild,v 1.7 2010/04/13 18:20:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7-r1.ebuild,v 1.8 2012/02/10 17:53:39 grobian Exp $
+
+EAPI="3"
inherit flag-o-matic eutils
@@ -10,18 +12,16 @@ SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="xterm"
DEPEND=">=sys-libs/ncurses-5.2-r2"
RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Fix segfault, bug 283508
epatch "${FILESDIR}/${P}-segfault-fix.patch"
+ epatch "${FILESDIR}/${P}-sanitise-includes.patch"
cd ./rc
@@ -37,8 +37,7 @@ src_compile() {
# Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
replace-flags "-Os" "-O2"
- econf --docdir=/usr/share/doc/${PF} || die
- emake || die
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF} || die
}
src_install() {