summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-07 01:46:55 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-07 01:46:55 +0000
commit00bdba7d0cee7ec37fb446cfa1fc4b88f9b700a6 (patch)
treeff0622c2fe59fe06e0f76be265624a1650a82597 /app-editors
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-00bdba7d0cee7ec37fb446cfa1fc4b88f9b700a6.tar.gz
gentoo-2-00bdba7d0cee7ec37fb446cfa1fc4b88f9b700a6.tar.bz2
gentoo-2-00bdba7d0cee7ec37fb446cfa1fc4b88f9b700a6.zip
umask fix #55780
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog9
-rw-r--r--app-editors/nano/files/1.3-nanopermsfix.patch12
-rw-r--r--app-editors/nano/files/digest-nano-1.3.2-r1 (renamed from app-editors/nano/files/digest-nano-1.3.2)0
-rw-r--r--app-editors/nano/files/digest-nano-1.3.3-r1 (renamed from app-editors/nano/files/digest-nano-1.3.3)0
-rw-r--r--app-editors/nano/nano-1.3.2-r1.ebuild (renamed from app-editors/nano/nano-1.3.2.ebuild)3
-rw-r--r--app-editors/nano/nano-1.3.3-r1.ebuild (renamed from app-editors/nano/nano-1.3.3.ebuild)3
6 files changed, 24 insertions, 3 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 977637918fc9..9e2fca2b77ad 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/nano
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.58 2004/06/30 03:24:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.59 2004/07/07 01:46:55 vapier Exp $
+
+*nano-1.3.3-r1 (06 Jul 2004)
+
+ 06 Jul 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.3-nanopermsfix.patch, +nano-1.3.2-r1.ebuild, -nano-1.3.2.ebuild,
+ +nano-1.3.3-r1.ebuild, -nano-1.3.3.ebuild:
+ Add umask fix from upstream for #55780 by Toni Suokas.
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> nano-1.3.2.ebuild:
stable on alpha, ia64
diff --git a/app-editors/nano/files/1.3-nanopermsfix.patch b/app-editors/nano/files/1.3-nanopermsfix.patch
new file mode 100644
index 000000000000..68d9f77104b8
--- /dev/null
+++ b/app-editors/nano/files/1.3-nanopermsfix.patch
@@ -0,0 +1,12 @@
+diff -ur nano-1.3.3/src/files.c nano-1.3.3-fixed/src/files.c
+--- nano-1.3.3/src/files.c 2004-06-21 23:03:00.000000000 -0400
++++ nano-1.3.3-fixed/src/files.c 2004-07-06 09:58:56.000000000 -0400
+@@ -1619,7 +1619,7 @@
+ * is now copied from joe, because wiggy says so *shrug*. */
+ fd = open(realname, O_WRONLY | O_CREAT |
+ (append == 1 ? O_APPEND : (tmp ? O_EXCL : O_TRUNC)),
+- S_IRUSR | S_IWUSR);
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+
+ /* Put the umask back to the user's original value. */
+ umask(original_umask);
diff --git a/app-editors/nano/files/digest-nano-1.3.2 b/app-editors/nano/files/digest-nano-1.3.2-r1
index 54ccd0c171ed..54ccd0c171ed 100644
--- a/app-editors/nano/files/digest-nano-1.3.2
+++ b/app-editors/nano/files/digest-nano-1.3.2-r1
diff --git a/app-editors/nano/files/digest-nano-1.3.3 b/app-editors/nano/files/digest-nano-1.3.3-r1
index aadcff3edca1..aadcff3edca1 100644
--- a/app-editors/nano/files/digest-nano-1.3.3
+++ b/app-editors/nano/files/digest-nano-1.3.3-r1
diff --git a/app-editors/nano/nano-1.3.2.ebuild b/app-editors/nano/nano-1.3.2-r1.ebuild
index 86117ff4af9d..d4d6e4198877 100644
--- a/app-editors/nano/nano-1.3.2.ebuild
+++ b/app-editors/nano/nano-1.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.2.ebuild,v 1.10 2004/07/07 00:45:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.2-r1.ebuild,v 1.1 2004/07/07 01:46:55 vapier Exp $
inherit eutils
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/1.3-nanopermsfix.patch
use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
use wsconvert && epatch ${FILESDIR}/${PV}-wsconvert.patch
}
diff --git a/app-editors/nano/nano-1.3.3.ebuild b/app-editors/nano/nano-1.3.3-r1.ebuild
index 415b89257cbd..bc396361152f 100644
--- a/app-editors/nano/nano-1.3.3.ebuild
+++ b/app-editors/nano/nano-1.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.3.ebuild,v 1.1 2004/06/29 01:35:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.3-r1.ebuild,v 1.1 2004/07/07 01:46:55 vapier Exp $
inherit eutils
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/1.3-nanopermsfix.patch
epatch ${FILESDIR}/${PV}-ws-default-off.patch
epatch ${FILESDIR}/${PV}-ifdeffix.patch
use nomac && epatch ${FILESDIR}/${PV}-nomac.patch