summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-11-18 21:56:44 +0000
committerUlrich Müller <ulm@gentoo.org>2010-11-18 21:56:44 +0000
commitf97774077dd5661227b64974228c8d63d38aa39e (patch)
tree9ffdee7d0b37959bd6acfb42cd11bae341a79e32 /app-editors/zile
parentRemove unused ebuilds (diff)
downloadgentoo-2-f97774077dd5661227b64974228c8d63d38aa39e.tar.gz
gentoo-2-f97774077dd5661227b64974228c8d63d38aa39e.tar.bz2
gentoo-2-f97774077dd5661227b64974228c8d63d38aa39e.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.3.21.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index 72050f2054d8..47686a2b737b 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.133 2010/11/11 17:35:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.134 2010/11/18 21:56:44 ulm Exp $
+
+*zile-2.3.21 (18 Nov 2010)
+
+ 18 Nov 2010; Ulrich Mueller <ulm@gentoo.org> +zile-2.3.21.ebuild:
+ Version bump.
11 Nov 2010; Markos Chandras <hwoarang@gentoo.org> zile-2.3.20.ebuild:
Stable on amd64 wrt bug #344541
diff --git a/app-editors/zile/zile-2.3.21.ebuild b/app-editors/zile/zile-2.3.21.ebuild
new file mode 100644
index 000000000000..e38216204912
--- /dev/null
+++ b/app-editors/zile/zile-2.3.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.21.ebuild,v 1.1 2010/11/18 21:56:44 ulm Exp $
+
+EAPI=3
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="livecd test valgrind"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/help2man
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf $(use test && use_with valgrind || echo "--without-valgrind")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # FAQ is installed by the build system in /usr/share/zile
+ dodoc AUTHORS BUGS NEWS README THANKS || die
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [ -e "${EROOT}"/usr/bin/emacs ] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}