summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-05 22:44:03 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-05 22:44:03 +0000
commit1d61756f87f7999f6e6a683fea021fe2be2160b3 (patch)
tree149240bfdd8b8d2aa7b1eda6f1ca680c3038e2d8 /app-editors/xmlcopyeditor
parentFix CVE-2012-xxxx. With access to /dev/nvidia* a malicious user could exploit... (diff)
downloadgentoo-2-1d61756f87f7999f6e6a683fea021fe2be2160b3.tar.gz
gentoo-2-1d61756f87f7999f6e6a683fea021fe2be2160b3.tar.bz2
gentoo-2-1d61756f87f7999f6e6a683fea021fe2be2160b3.zip
EAPI bump and add prefix deps/keywords
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog7
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild15
2 files changed, 13 insertions, 9 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index 7b4505bcc4c5..39b397e1e57e 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/xmlcopyeditor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.20 2012/08/01 07:26:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.21 2012/08/05 22:44:03 ottxor Exp $
+
+ 05 Aug 2012; Christoph Junghans <ottxor@gentoo.org>
+ xmlcopyeditor-1.2.0.6.ebuild:
+ EAPI bump and add prefix deps/keywords
01 Aug 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
xmlcopyeditor-1.2.0.6.ebuild:
@@ -106,4 +110,3 @@
+xmlcopyeditor-1.1.0.4.ebuild:
Initial import. Thanks to Xavier Neys <neysx@gentoo.org> who made the
guidexml templates and the first ebuild #167372
-
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
index 4c1ff1477934..9be6be9536c4 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild,v 1.3 2012/08/01 07:26:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild,v 1.4 2012/08/05 22:44:03 ottxor Exp $
-EAPI="2"
+EAPI="4"
WX_GTK_VER="2.8"
MY_P=${P}-2
@@ -16,25 +16,26 @@ SRC_URI="mirror://sourceforge/xml-copy-editor/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="guidexml"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="aqua guidexml"
RDEPEND=">=dev-libs/libxml2-2.7.3-r1
dev-libs/libxslt
dev-libs/xerces-c[icu]
dev-libs/libpcre
app-text/aspell
- x11-libs/wxGTK:2.8[X]"
+ !aqua? ( x11-libs/wxGTK:2.8[X] )
+ aqua? ( x11-libs/wxGTK:2.8[aqua] )"
DEPEND="${RDEPEND}
dev-libs/boost"
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
if use guidexml; then
insinto /usr/share/xmlcopyeditor/templates/
for TEMPLATE in "${WORKDIR}"/GuideXML-templates/*.xml; do
- newins "${TEMPLATE}" "${TEMPLATE##*/}" || die "GuideXML templates failed"
+ newins "${TEMPLATE}" "${TEMPLATE##*/}"
done
fi