summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2006-10-23 03:22:08 +0000
committerMike Kelly <pioto@gentoo.org>2006-10-23 03:22:08 +0000
commitf915684f808b94c5b7448233f411ac880f7c826b (patch)
treef1e5e919a3384e418eb7ef7f7ecb2ac1eb962109 /app-editors/vim/vim-7.0.146.ebuild
parentParallelize install_grades target in Mmake.rules. (diff)
downloadgentoo-2-f915684f808b94c5b7448233f411ac880f7c826b.tar.gz
gentoo-2-f915684f808b94c5b7448233f411ac880f7c826b.tar.bz2
gentoo-2-f915684f808b94c5b7448233f411ac880f7c826b.zip
Version bump.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'app-editors/vim/vim-7.0.146.ebuild')
-rw-r--r--app-editors/vim/vim-7.0.146.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.0.146.ebuild b/app-editors/vim/vim-7.0.146.ebuild
new file mode 100644
index 000000000000..7f94dfaa8415
--- /dev/null
+++ b/app-editors/vim/vim-7.0.146.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0.146.ebuild,v 1.1 2006/10/23 03:22:08 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+ !<app-editors/nvi-1.81.5-r4
+ !minimal? ( ~app-editors/vim-core-${PV} )"