summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2005-10-03 00:52:53 +0000
committerJory Pratt <anarchy@gentoo.org>2005-10-03 00:52:53 +0000
commit8d4f390582712b7b08b8dd51805e48d0cb7b216e (patch)
tree19bec7dddffca50029285b686f4c98d96cbaba49 /app-editors/nvu/nvu-0.90-r2.ebuild
parentVersion bump (diff)
downloadgentoo-2-8d4f390582712b7b08b8dd51805e48d0cb7b216e.tar.gz
gentoo-2-8d4f390582712b7b08b8dd51805e48d0cb7b216e.tar.bz2
gentoo-2-8d4f390582712b7b08b8dd51805e48d0cb7b216e.zip
mozilla.eclass dropped in favor of mozconfig.eclass for gtk2 depreciation
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'app-editors/nvu/nvu-0.90-r2.ebuild')
-rw-r--r--app-editors/nvu/nvu-0.90-r2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-editors/nvu/nvu-0.90-r2.ebuild b/app-editors/nvu/nvu-0.90-r2.ebuild
new file mode 100644
index 000000000000..bdc2645bec5c
--- /dev/null
+++ b/app-editors/nvu/nvu-0.90-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-0.90-r2.ebuild,v 1.1 2005/10/03 00:52:53 anarchy Exp $
+
+inherit eutils mozconfig flag-o-matic
+
+DESCRIPTION="A WYSIWG web editor for linux similiar to Dreamweaver"
+HOMEPAGE="http://www.nvu.com/"
+SRC_URI="http://cvs.nvu.com/download/${P}-sources.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="x86 ppc sparc amd64"
+IUSE=""
+DEPEND="sys-apps/gawk
+ dev-lang/perl
+ app-doc/doxygen
+ >=media-libs/freetype-2.1.9-r1"
+
+S=${WORKDIR}/mozilla
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix those darn directories! Make something more "standard"
+ # That can extend to future versions with much more ease. - Chris
+ epatch ${FILESDIR}/1.0/nvu-0.50-dir.patch
+ epatch ${FILESDIR}/1.0/nvu-0.50-freetype-compile.patch
+
+ # I had to manually edit the mozconfig.linux file as it
+ # has some quirks... just copy the darn thing over :) - Chris
+ # cp ${FILESDIR}/mozconfig ${S}/.mozconfig
+ # remove --enable-optimize and let the code below
+ # add the appropriate one - basic
+ grep -v enable-optimize ${FILESDIR}/mozconfig2 > .mozconfig
+
+ # copied from mozilla.eclass (modified slightly),
+ # otherwise it defaults to -O which crashes on startup for me - basic
+ # Set optimization level based on CFLAGS
+ if is-flag -O0; then
+ echo 'ac_add_options --enable-optimize=-O0' >> .mozconfig
+ elif [[ ${ARCH} == alpha || ${ARCH} == amd64 || ${ARCH} == ia64 ]]; then
+ # more than -O1 causes segfaults on 64-bit (bug 33767)
+ echo 'ac_add_options --enable-optimize=-O1' >> .mozconfig
+ elif is-flag -O1; then
+ echo 'ac_add_options --enable-optimize=-O1' >> .mozconfig
+ else
+ # mozilla fallback
+ echo 'ac_add_options --enable-optimize=-O2' >> .mozconfig
+ fi
+}
+
+src_compile() {
+ # The build system is a weeee bit sensitive to naughty -O flags.
+ # filter them out and let the build system figure out what
+ # won't let it die :) - Chris
+ filter-flags '-O*'
+ # epatch ${FILESDIR}/nvu-0.80-mozconfig.patch
+
+ make -f client.mk build_all
+}
+
+src_install() {
+
+ # patch the final nvu binary to workaround bug #67658
+ epatch ${FILESDIR}/1.0/nvu-0.50-nvu.patch
+
+ make -f client.mk DESTDIR=${D} install || die
+
+ #menu entry for gnome/kde
+ insinto /usr/share/applications
+ doins ${FILESDIR}/nvu.desktop
+}