summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-02-20 16:09:43 +0000
committerAron Griffis <agriffis@gentoo.org>2002-02-20 16:09:43 +0000
commit11994b753894aa03d7f82c93fbb7e6b0980b4e5b (patch)
tree9b309f099aad4e10382bec585dce29dc05147893 /app-editors/nano
parentUpdated to 1.4.5 (diff)
downloadgentoo-2-11994b753894aa03d7f82c93fbb7e6b0980b4e5b.tar.gz
gentoo-2-11994b753894aa03d7f82c93fbb7e6b0980b4e5b.tar.bz2
gentoo-2-11994b753894aa03d7f82c93fbb7e6b0980b4e5b.zip
Updated to 1.0.8
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog23
-rw-r--r--app-editors/nano/files/digest-nano-1.0.81
-rw-r--r--app-editors/nano/nano-1.0.8.ebuild39
3 files changed, 55 insertions, 8 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 4a15d5b24dbc..5906018e36ac 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for app-editors/nano
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.1 2002/02/01 21:53:01 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.2 2002/02/20 16:09:43 agriffis Exp $
+
+*nano-1.0.8 (20 Feb 2002)
+
+ 20 Feb 2002; Aron Griffis <agriffis@gentoo.org> nano-1.0.8.ebuild :
+
+ Updated to 1.0.8. Added USE-conditional slang compilation.
*nano-1.0.6 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/app-editors/nano/files/digest-nano-1.0.8 b/app-editors/nano/files/digest-nano-1.0.8
new file mode 100644
index 000000000000..ad1304006d85
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.8
@@ -0,0 +1 @@
+MD5 84743b50f839013b6bba654c7ae707bc nano-1.0.8.tar.gz 439253
diff --git a/app-editors/nano/nano-1.0.8.ebuild b/app-editors/nano/nano-1.0.8.ebuild
new file mode 100644
index 000000000000..f5112bec131d
--- /dev/null
+++ b/app-editors/nano/nano-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.8.ebuild,v 1.1 2002/02/20 16:09:43 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="clone of Pico with more functions in a smaller size"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.4-r1 )"
+
+src_compile() {
+ local myflags
+ if use slang; then
+ myflags="--with-slang"
+ else
+ myflags="--without-slang"
+ fi
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --enable-extra \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myflags} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ if use bootcd || use build; then
+ rm -rf ${D}/usr/share
+ else
+ dodoc COPYING ChangeLog README
+ fi
+}