summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-25 17:46:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-25 17:46:29 +0000
commit6abc67da841dc5ac5e6ed1421de11041da0b577b (patch)
tree6431252a88006e358c52bad1927ca88dd12ccbf1 /app-editors/mousepad
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-6abc67da841dc5ac5e6ed1421de11041da0b577b.tar.gz
gentoo-2-6abc67da841dc5ac5e6ed1421de11041da0b577b.tar.bz2
gentoo-2-6abc67da841dc5ac5e6ed1421de11041da0b577b.zip
Use xfconf.eclass
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/metadata.xml2
-rw-r--r--app-editors/mousepad/mousepad-0.2.16.ebuild27
2 files changed, 16 insertions, 13 deletions
diff --git a/app-editors/mousepad/metadata.xml b/app-editors/mousepad/metadata.xml
index 826e2ca93209..d56729e92f8e 100644
--- a/app-editors/mousepad/metadata.xml
+++ b/app-editors/mousepad/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>xfce</herd>
+ <herd>xfce</herd>
</pkgmetadata>
diff --git a/app-editors/mousepad/mousepad-0.2.16.ebuild b/app-editors/mousepad/mousepad-0.2.16.ebuild
index 5aa06506948e..da41adfe3e43 100644
--- a/app-editors/mousepad/mousepad-0.2.16.ebuild
+++ b/app-editors/mousepad/mousepad-0.2.16.ebuild
@@ -1,24 +1,27 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/mousepad-0.2.16.ebuild,v 1.10 2009/07/27 17:35:02 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/mousepad-0.2.16.ebuild,v 1.11 2009/08/25 17:46:29 ssuominen Exp $
-EAPI=1
+EAPI=2
+inherit xfconf
-inherit xfce4
-
-XFCE_VERSION=4.6.0
-
-xfce4_core
-
-DESCRIPTION="Text editor"
+DESCRIPTION="A simple text editor for Xfce"
HOMEPAGE="http://www.xfce.org/projects/mousepad/"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}"
+ >=xfce-base/libxfcegui4-4.4"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
dev-util/intltool"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}