summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 17:18:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 17:18:34 +0000
commitdb43fd651817d9487c9f33ac72072f53e7738e03 (patch)
tree45f9744d9d6a4a44cc28199e61b310841fc68819 /app-editors/leo
parentDelete older ebuilds. (diff)
downloadgentoo-2-db43fd651817d9487c9f33ac72072f53e7738e03.tar.gz
gentoo-2-db43fd651817d9487c9f33ac72072f53e7738e03.tar.bz2
gentoo-2-db43fd651817d9487c9f33ac72072f53e7738e03.zip
Version bump.
(Portage version: 15825-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/leo')
-rw-r--r--app-editors/leo/ChangeLog11
-rw-r--r--app-editors/leo/files/leo-4.7.1-fix_syntax_errors.patch32
-rw-r--r--app-editors/leo/leo-4.7.1.ebuild40
3 files changed, 81 insertions, 2 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index 78ba56f426a4..3c0750437e7d 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/leo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.14 2009/10/15 11:38:16 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.15 2010/03/13 17:18:33 arfrever Exp $
+
+*leo-4.7.1 (13 Mar 2010)
+
+ 13 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -leo-4.2.ebuild, -leo-4.4.7-r1.ebuild, +leo-4.7.1.ebuild,
+ +files/leo-4.7.1-fix_syntax_errors.patch, -files/leoConfig.py.patch:
+ Version bump.
15 Oct 2009; Markus Meier <maekke@gentoo.org> leo-4.6.3.ebuild:
amd64/x86 stable, bug #287946
diff --git a/app-editors/leo/files/leo-4.7.1-fix_syntax_errors.patch b/app-editors/leo/files/leo-4.7.1-fix_syntax_errors.patch
new file mode 100644
index 000000000000..2809f2d3f2b2
--- /dev/null
+++ b/app-editors/leo/files/leo-4.7.1-fix_syntax_errors.patch
@@ -0,0 +1,32 @@
+--- leo/plugins/ConceptualSort.py
++++ leo/plugins/ConceptualSort.py
+@@ -207,8 +207,7 @@
+ usort = compile( code, 'user_sort', 'exec' )
+ def lcsort2( a, b, atts =atts ):
+ z = {}
+- # exec usort in {}, z
+- exec(usort,{},z)
++ exec usort in {}, z
+ rv = z[ 'user_sort' ]( a, b, atts )
+ return rv
+ self.children.sort( lcsort2 )
+--- leo/plugins/LeoN.py
++++ leo/plugins/LeoN.py
+@@ -216,7 +216,7 @@
+
+ # receive an operation to execute
+ if dbg >=1:
+- print("Site %i;%s; '%s'; receiving %s"%(self.site_index, self.state_vector, self.get_text(), t_op)
++ print("Site %i;%s; '%s'; receiving %s"%(self.site_index, self.state_vector, self.get_text(), t_op))
+
+
+ if is_causally_ready(t_op, self): # check if it is causally ready
+@@ -308,7 +308,7 @@
+ if undoed: # if there was an undo, then redo
+ if dbg>=1:
+ print("Site %i; '%s'; undoed %s; executed %s;"%(
+- self.site_index, self.get_text(), undoed, EOnew) # just for debugging
++ self.site_index, self.get_text(), undoed, EOnew)) # just for debugging
+ EOoL = [] # EO'm+1 List
+
+ EOoL.append( IT( HB[m+1], EOnew ) )
diff --git a/app-editors/leo/leo-4.7.1.ebuild b/app-editors/leo/leo-4.7.1.ebuild
new file mode 100644
index 000000000000..7b5caa145332
--- /dev/null
+++ b/app-editors/leo/leo-4.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.7.1.ebuild,v 1.1 2010/03/13 17:18:33 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_P="Leo-${PV}-final"
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-text/silvercity
+ dev-python/PyQt4[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-fix_syntax_errors.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r leo/doc/html/* || die "dohtml failed"
+ dodoc leo/doc/README.TXT || die "dodoc failed"
+}