summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-03-08 21:28:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-03-08 21:28:17 +0000
commit5c4aaf95dad44812aa820b0ac903af7da319dd98 (patch)
treef01386ce2e152c35baa94b8f38a76d72f8118732 /app-editors/gedit-plugins
parentFix building with libpng14. (diff)
downloadgentoo-2-5c4aaf95dad44812aa820b0ac903af7da319dd98.tar.gz
gentoo-2-5c4aaf95dad44812aa820b0ac903af7da319dd98.tar.bz2
gentoo-2-5c4aaf95dad44812aa820b0ac903af7da319dd98.zip
Version bump. Do not install unused *.la files, do not let build pre-compile python code. i18n updates and a couple of fixes.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog11
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.28.0.ebuild (renamed from app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild)36
2 files changed, 39 insertions, 8 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 29472b7d33fb..b84d14215b99 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/gedit-plugins
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.5 2009/08/27 17:11:49 mrpouet Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.6 2010/03/08 21:28:17 eva Exp $
+
+*gedit-plugins-2.28.0 (08 Mar 2010)
+
+ 08 Mar 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ -gedit-plugins-2.26.2.ebuild, +gedit-plugins-2.28.0.ebuild:
+ Version bump. Do not install unused *.la files, do not let build
+ pre-compile python code. i18n updates and a couple of fixes.
*gedit-plugins-2.26.3 (27 Aug 2009)
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.28.0.ebuild
index 4e38c8293661..95e1f2bc8fcc 100644
--- a/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-2.28.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild,v 1.5 2009/08/17 11:15:07 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.28.0.ebuild,v 1.1 2010/03/08 21:28:17 eva Exp $
EAPI="2"
GCONF_DEBUG="no"
-inherit gnome2
+inherit gnome2 multilib python
DESCRIPTION="Offical plugins for gedit."
HOMEPAGE="http://live.gnome.org/GeditPlugins"
@@ -37,10 +37,9 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
-DOCS="AUTHORS NEWS"
+DOCS="AUTHORS NEWS ChangeLog*"
-pkg_setup()
-{
+pkg_setup() {
local myplugins="codecomment"
for plugin in ${IUSE/python}; do
@@ -57,6 +56,31 @@ pkg_setup()
$(use_enable python)"
}
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
src_test() {
emake check || die "make check failed"
}
+
+src_install() {
+ gnome2_src_install
+ # gedit doesn't rely on *.la files
+ find "${D}" -name "*.la" -delete || die "*.la files removal failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}