summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-10 10:39:30 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-10 10:39:30 +0000
commit9ef1d0946e1c9ae951c368c0ecd50945c57d8d4b (patch)
tree875207ea5f88cc3fd97f7254c5ff7f1fcfc05adb /app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
parentppc64 stable wrt #324077 (diff)
downloadgentoo-2-9ef1d0946e1c9ae951c368c0ecd50945c57d8d4b.tar.gz
gentoo-2-9ef1d0946e1c9ae951c368c0ecd50945c57d8d4b.tar.bz2
gentoo-2-9ef1d0946e1c9ae951c368c0ecd50945c57d8d4b.zip
Don't rename GNU Info files, bug 306445.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
index 982f2bf66525..ce56510cb9ab 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.12 2010/09/25 11:32:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.13 2010/10/10 10:39:30 ulm Exp $
EAPI=2
@@ -225,16 +225,15 @@ src_install () {
mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
|| die "moving Emacs executable failed"
- # move info documentation to the correct place
- for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
- mv "${i}" "${i}.info" || die "mv info failed"
- done
-
# move man pages to the correct place
for m in "${D}"/usr/share/man/man1/* ; do
mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
done
+ # move info dir to avoid collisions with the dir file generated by portage
+ mv "${D}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} \
+ || die "moving info dir failed"
+
# avoid collision between slots, see bug #169033 e.g.
rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${D}"/usr/share/{applications,icons}
@@ -277,15 +276,17 @@ pkg_preinst() {
# Depending on Portage version and user's settings, the Info dir file
# may have been compressed or removed. We rebuild it in both cases.
local infodir=/usr/share/info/${EMACS_SUFFIX} f
- if [ -f "${D}"${infodir}/dir.info ]; then
+ if [ -f "${D}"${infodir}/dir.orig ]; then
# prefer existing file if it has survived to here
- mv "${D}"${infodir}/dir{.info,} || die "mv dir.info failed"
+ mv "${D}"${infodir}/dir{.orig,} || die "moving info dir failed"
else
einfo "Regenerating Info directory index in ${infodir} ..."
rm -f "${D}"${infodir}/dir{,.*}
- for f in "${D}"${infodir}/*.info*; do
- [[ ${f##*/} != *[0-9].info* && -e ${f} ]] \
- && install-info --info-dir="${D}"${infodir} "${f}" &>/dev/null
+ for f in "${D}"${infodir}/*; do
+ if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
+ install-info --info-dir="${D}"${infodir} "${f}" \
+ || die "install-info failed"
+ fi
done
fi
}