summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-02 14:18:11 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-02 14:18:11 +0000
commit9119633e8c3d29f69fbf1d5386d62d2ca4c83424 (patch)
tree53098413d09881fe24db1ccb86729d805c88e35d /app-editors/emacs-cvs
parentStable on amd64/x86 for 2.6.24 compatibility. (diff)
downloadgentoo-2-9119633e8c3d29f69fbf1d5386d62d2ca4c83424.tar.gz
gentoo-2-9119633e8c3d29f69fbf1d5386d62d2ca4c83424.tar.bz2
gentoo-2-9119633e8c3d29f69fbf1d5386d62d2ca4c83424.zip
Fix logic of libotf flag.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
index 4e2783604a90..d05650e1c198 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.3 2008/02/02 09:14:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.4 2008/02/02 14:18:11 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -46,6 +46,7 @@ RDEPEND="sys-libs/ncurses
xpm? ( x11-libs/libXpm )
xft? (
media-libs/fontconfig
+ media-libs/freetype
virtual/xft
libotf? ( >=dev-libs/libotf-0.9.4 )
)
@@ -129,8 +130,12 @@ src_compile() {
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_enable xft font-backend)"
- myconf="${myconf} $(use_with xft freetype)"
- myconf="${myconf} $(use_with xft) $(use_with libotf)"
+ myconf="${myconf} $(use_with xft freetype) $(use_with xft)"
+ if use xft && use libotf; then
+ myconf="${myconf} --with-libotf"
+ else
+ myconf="${myconf} --without-libotf"
+ fi
myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
myconf="${myconf} $(use_with gif) $(use_with png)"
myconf="${myconf} $(use_with xpm) $(use_with svg rsvg)"