summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-05-01 22:56:10 +0000
committerHanno Böck <hanno@gentoo.org>2010-05-01 22:56:10 +0000
commit39835dec9d207cab41296e9c5c78f9baa2ff52f3 (patch)
treeb4820fab6758b08766524c63f023a8a3e88fd69e /app-editors/efte
parentversion bump (diff)
downloadgentoo-2-39835dec9d207cab41296e9c5c78f9baa2ff52f3.tar.gz
gentoo-2-39835dec9d207cab41296e9c5c78f9baa2ff52f3.tar.bz2
gentoo-2-39835dec9d207cab41296e9c5c78f9baa2ff52f3.zip
efte version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/efte')
-rw-r--r--app-editors/efte/ChangeLog9
-rw-r--r--app-editors/efte/efte-1.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/app-editors/efte/ChangeLog b/app-editors/efte/ChangeLog
index 89a835279437..6b62f3064cd7 100644
--- a/app-editors/efte/ChangeLog
+++ b/app-editors/efte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/efte
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.8 2009/10/27 21:51:06 scarabeus Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.9 2010/05/01 22:56:10 hanno Exp $
+
+*efte-1.1 (01 May 2010)
+
+ 01 May 2010; Hanno Boeck <hanno@gentoo.org> +efte-1.1.ebuild:
+ Version bump and install docs to correct dir, fix #297415.
27 Oct 2009; Tomáš Chvátal <scarabeus@gentoo.org> -efte-0.95.ebuild,
-efte-0.96.ebuild:
diff --git a/app-editors/efte/efte-1.1.ebuild b/app-editors/efte/efte-1.1.ebuild
new file mode 100644
index 000000000000..1f7323346968
--- /dev/null
+++ b/app-editors/efte/efte-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/efte-1.1.ebuild,v 1.1 2010/05/01 22:56:10 hanno Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="A fast text editor supporting folding, syntax highlighting, etc."
+HOMEPAGE="http://efte.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gpm X"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libXpm
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ media-fonts/font-misc-misc
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_build gpm)
+ $(cmake-utils_use_build X)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}/usr/share/doc/${PN}/COPYING"
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
+ prepalldocs
+}