summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2008-01-07 14:18:53 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2008-01-07 14:18:53 +0000
commit54aba8c7b30c8e215b7b61f144054b4ea25b60c2 (patch)
tree75e045c0ba7961bb84f24e2951fe7b9282f730f0 /app-editors/amyedit
parentVersion bump. (diff)
downloadgentoo-2-54aba8c7b30c8e215b7b61f144054b4ea25b60c2.tar.gz
gentoo-2-54aba8c7b30c8e215b7b61f144054b4ea25b60c2.tar.bz2
gentoo-2-54aba8c7b30c8e215b7b61f144054b4ea25b60c2.zip
Remove private Glib::KeyFile usage as >=glibmm-2.14 provides an alternative, #204624
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-editors/amyedit')
-rw-r--r--app-editors/amyedit/ChangeLog11
-rw-r--r--app-editors/amyedit/amyedit-1.0-r1.ebuild27
-rw-r--r--app-editors/amyedit/files/amyedit-1.0-keyfile.patch62
-rw-r--r--app-editors/amyedit/files/digest-amyedit-1.0-r13
4 files changed, 101 insertions, 2 deletions
diff --git a/app-editors/amyedit/ChangeLog b/app-editors/amyedit/ChangeLog
index 8d4c7b4f3b62..d36f061c3abc 100644
--- a/app-editors/amyedit/ChangeLog
+++ b/app-editors/amyedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/amyedit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/ChangeLog,v 1.14 2007/10/11 18:48:29 remi Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/ChangeLog,v 1.15 2008/01/07 14:18:52 pclouds Exp $
+
+*amyedit-1.0-r1 (07 Jan 2008)
+
+ 07 Jan 2008; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ +files/amyedit-1.0-keyfile.patch, +amyedit-1.0-r1.ebuild:
+ Remove private Glib::KeyFile usage as >=glibmm-2.14 provides an alternative,
+ #204624
11 Oct 2007; Rémi Cardona <remi@gentoo.org> amyedit-0.9.ebuild,
amyedit-1.0.ebuild:
diff --git a/app-editors/amyedit/amyedit-1.0-r1.ebuild b/app-editors/amyedit/amyedit-1.0-r1.ebuild
new file mode 100644
index 000000000000..f5a271cc258c
--- /dev/null
+++ b/app-editors/amyedit/amyedit-1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/amyedit-1.0-r1.ebuild,v 1.1 2008/01/07 14:18:52 pclouds Exp $
+
+inherit eutils
+
+DESCRIPTION=" AmyEdit is a LaTeX editor"
+HOMEPAGE="http://amyedit.sf.net"
+SRC_URI="mirror://sourceforge/amyedit/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=dev-cpp/gtkmm-2.6
+ >=dev-cpp/glibmm-2.14
+ =x11-libs/gtksourceview-1*
+ app-text/aspell"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-keyfile.patch"
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README TODO || die
+}
diff --git a/app-editors/amyedit/files/amyedit-1.0-keyfile.patch b/app-editors/amyedit/files/amyedit-1.0-keyfile.patch
new file mode 100644
index 000000000000..fb9f9ac908fc
--- /dev/null
+++ b/app-editors/amyedit/files/amyedit-1.0-keyfile.patch
@@ -0,0 +1,62 @@
+diff -ur amyedit-1.0/src/main.cc amyedit-1.0.new/src/main.cc
+--- amyedit-1.0/src/main.cc 2006-03-14 06:08:32.000000000 +0700
++++ amyedit-1.0.new/src/main.cc 2008-01-07 20:45:39.000000000 +0700
+@@ -54,7 +54,6 @@
+
+ #include "AmyEdit.hh"
+ #include "gtksourceviewmm/init.hh"
+-#include "gtkmm_extra/keyfile.h"
+ #include "Utils.hh"
+
+ int main(int argc, char **argv)
+@@ -65,7 +64,6 @@
+
+ Gtk::Main m(&argc, &argv);
+ Gtk::SourceViewmm_init();
+- Glib::keyfile_init();
+
+ /* TODO This should probably be removed and created on demand */
+
+Only in amyedit-1.0.new/src: main.o
+Only in amyedit-1.0.new/src: Makefile
+diff -ur amyedit-1.0/src/Makefile.am amyedit-1.0.new/src/Makefile.am
+--- amyedit-1.0/src/Makefile.am 2006-03-08 05:44:53.000000000 +0700
++++ amyedit-1.0.new/src/Makefile.am 2008-01-07 20:41:46.000000000 +0700
+@@ -30,8 +30,7 @@
+ gtksourceviewmm/sourcelanguage.cpp \
+ gtksourceviewmm/sourcelanguagesmanager.cpp \
+ gtksourceviewmm/sourceview.cpp \
+- gtksourceviewmm/init.cc \
+- gtkmm_extra/keyfile.cc
++ gtksourceviewmm/init.cc
+
+ headers = \
+ AboutDialog.hh \
+@@ -54,15 +53,13 @@
+ gtksourceviewmm/sourcelanguage.h \
+ gtksourceviewmm/sourcelanguagesmanager.h \
+ gtksourceviewmm/sourceview.h \
+- gtksourceviewmm/init.hh \
+- gtkmm_extra/keyfile.h
++ gtksourceviewmm/init.hh
+
+ privateheaders= \
+ gtksourceviewmm/private/sourcebuffer_p.h \
+ gtksourceviewmm/private/sourcelanguage_p.h \
+ gtksourceviewmm/private/sourcelanguagesmanager_p.h \
+ gtksourceviewmm/private/sourceview_p.h \
+- gtkmm_extra/private/keyfile_p.h \
+ Utils_p.hh
+
+ if PRECOMPILE_HEADERS
+diff -ur amyedit-1.0/src/PrefStruct.hh amyedit-1.0.new/src/PrefStruct.hh
+--- amyedit-1.0/src/PrefStruct.hh 2006-03-09 06:54:41.000000000 +0700
++++ amyedit-1.0.new/src/PrefStruct.hh 2008-01-07 20:46:32.000000000 +0700
+@@ -24,7 +24,6 @@
+
+ #include "Preferences.hh"
+ #include <glibmm/ustring.h>
+-#include <gtkmm_extra/keyfile.h>
+ #include <iostream>
+
+ class PrefStruct
diff --git a/app-editors/amyedit/files/digest-amyedit-1.0-r1 b/app-editors/amyedit/files/digest-amyedit-1.0-r1
new file mode 100644
index 000000000000..1f24a2e0d1ca
--- /dev/null
+++ b/app-editors/amyedit/files/digest-amyedit-1.0-r1
@@ -0,0 +1,3 @@
+MD5 662f5d6cc37c5838e2dc5a4a6abb812d amyedit-1.0.tar.bz2 297769
+RMD160 b08ee643f2e6021e6ad7a3382c394106ea504298 amyedit-1.0.tar.bz2 297769
+SHA256 9aa88340266827bd83715d495b7e1f2c1ca7100ff9f7586877c1b4d3ec67f228 amyedit-1.0.tar.bz2 297769