summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-09-03 00:49:45 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-09-03 00:49:45 +0000
commit25911dd1555900a3e9aeca511b838a3c8802cdac (patch)
treed96838f4f354f08ab7357c52964330c968b86026 /app-doc
parentVersion bump. (diff)
downloadgentoo-2-25911dd1555900a3e9aeca511b838a3c8802cdac.tar.gz
gentoo-2-25911dd1555900a3e9aeca511b838a3c8802cdac.tar.bz2
gentoo-2-25911dd1555900a3e9aeca511b838a3c8802cdac.zip
More updates to force qmake to use the right config settings.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog6
-rw-r--r--app-doc/doxygen/doxygen-1.7.4.ebuild20
2 files changed, 18 insertions, 8 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 74a3709427bf..b128b6013bc2 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/doxygen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.203 2011/04/09 18:09:46 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.204 2011/09/03 00:49:45 nerdboy Exp $
+
+ 03 Sep 2011; Steve Arnold <nerdboy@gentoo.org> doxygen-1.7.4.ebuild:
+ More updates to force qmake to use the right config settings; should
+ also fix bug #378963. Qmake could really use a nice eclass...
*doxygen-1.7.4 (09 Apr 2011)
diff --git a/app-doc/doxygen/doxygen-1.7.4.ebuild b/app-doc/doxygen/doxygen-1.7.4.ebuild
index f82f7c44c789..49c6d31b84c7 100644
--- a/app-doc/doxygen/doxygen-1.7.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.7.4.ebuild,v 1.1 2011/04/09 18:09:46 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.7.4.ebuild,v 1.2 2011/09/03 00:49:45 nerdboy Exp $
EAPI=3
@@ -62,6 +62,10 @@ src_prepare() {
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die "sed 3 failed"
+ # fix qmake spec problem
+# sed -i.orig -e "s:spec macx-g++:spec gentoo:" \
+# addon/doxywizard/Makefile || die "sed 4 failed"
+
# add native TCL support
use tcl && epatch "${WORKDIR}"/${PN}-1.7-tcl_support.patch
@@ -104,16 +108,18 @@ src_configure() {
}
src_compile() {
- CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" LFLAGS+="${ELDFLAGS}" \
- emake all || die 'emake failed'
- # force stupid qmake to use LDFLAGS - yes, it's a big kluge...
+ # force stupid qmake to behave - yes, it's a big kluge...
if use qt4 ; then
- rm -f bin/doxywizard
sed -i -e "s|\-Wl,\-O1 |\-Wl,\-O1 ${ELDFLAGS} |" \
- addon/doxywizard/Makefile.doxywizard
- make -C addon/doxywizard
+ -e "s|= g++|= $(tc-getCXX)|" \
+ -e "s|usr/local/Qt4.6|usr/share/qt4|g" \
+ -e "s|macx-g++ -macx|linux-g++|" \
+ addon/doxywizard/Makefile.doxywizard \
+ || die "qmake sed hack failed"
fi
+ CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" LFLAGS+="${ELDFLAGS}" \
+ emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.
# errors here are not considered fatal, hence the ewarn message