summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-04-12 19:13:45 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-04-12 19:13:45 +0000
commitd60cac769d5b4a916475b29f25fdc9a555111923 (patch)
tree6e51741afd7ee0e223d986d2864d81423d8c44e2 /app-doc/root-docs
parentRemove old. (diff)
downloadgentoo-2-d60cac769d5b4a916475b29f25fdc9a555111923.tar.gz
gentoo-2-d60cac769d5b4a916475b29f25fdc9a555111923.tar.bz2
gentoo-2-d60cac769d5b4a916475b29f25fdc9a555111923.zip
version bump
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'app-doc/root-docs')
-rw-r--r--app-doc/root-docs/ChangeLog8
-rw-r--r--app-doc/root-docs/files/root-docs-6.02.05-jsroot.patch11
-rw-r--r--app-doc/root-docs/root-docs-6.02.05.ebuild137
3 files changed, 155 insertions, 1 deletions
diff --git a/app-doc/root-docs/ChangeLog b/app-doc/root-docs/ChangeLog
index 41511e1d3ddd..f543f4a8e6cd 100644
--- a/app-doc/root-docs/ChangeLog
+++ b/app-doc/root-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/root-docs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/ChangeLog,v 1.48 2015/04/11 11:29:10 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/ChangeLog,v 1.49 2015/04/12 19:13:45 bircoph Exp $
+
+*root-docs-6.02.05 (12 Apr 2015)
+
+ 12 Apr 2015; Andrew Savchenko <bircoph@gentoo.org> +root-docs-6.02.05.ebuild,
+ +files/root-docs-6.02.05-jsroot.patch:
+ Version bump fro science overlay.
11 Apr 2015; Andrew Savchenko <bircoph@gentoo.org> root-docs-5.34.26.ebuild,
root-docs-5.34.28.ebuild:
diff --git a/app-doc/root-docs/files/root-docs-6.02.05-jsroot.patch b/app-doc/root-docs/files/root-docs-6.02.05-jsroot.patch
new file mode 100644
index 000000000000..1ea170e84a71
--- /dev/null
+++ b/app-doc/root-docs/files/root-docs-6.02.05-jsroot.patch
@@ -0,0 +1,11 @@
+--- root-6.02.05/documentation/JSROOT/JSROOT.md.orig 2015-02-09 11:59:47.000000000 +0300
++++ root-6.02.05/documentation/JSROOT/JSROOT.md 2015-04-05 19:13:24.010358387 +0300
+@@ -198,7 +198,7 @@
+ <div id="drawing">loading...</div>
+ </body>
+
+-Internally, the JSROOT.loadScript(urllist, callback, debug) method is used. It can be useful when some other scripts should be loaded as well. __urllist__ is a string with scripts names, separated by ';' symbol. If a script name starts with __$$$__ (triple dollar sign), the script will be loaded from a location relative to the main JSROOT directory.
++Internally, the JSROOT.loadScript(urllist, callback, debug) method is used. It can be useful when some other scripts should be loaded as well. __urllist__ is a string with scripts names, separated by ';' symbol. If a script name starts with __\$\$\$__ (triple dollar sign), the script will be loaded from a location relative to the main JSROOT directory.
+ This location is automatically detected when JSRootCore.js script is loaded.
+
+
diff --git a/app-doc/root-docs/root-docs-6.02.05.ebuild b/app-doc/root-docs/root-docs-6.02.05.ebuild
new file mode 100644
index 000000000000..6f07876a4675
--- /dev/null
+++ b/app-doc/root-docs/root-docs-6.02.05.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/root-docs-6.02.05.ebuild,v 1.1 2015/04/12 19:13:45 bircoph Exp $
+
+EAPI=5
+
+ROOT_PN="root"
+ROOFIT_DOC_PV=2.91-33
+ROOFIT_QS_DOC_PV=3.00
+TMVA_DOC_PV=4.2.0
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EVCS_OFFLINE=yes # we need exactly the same checkout as root itself
+ EGIT_REPO_URI="http://root.cern.ch/git/root.git"
+else
+ SRC_URI="ftp://root.cern.ch/${ROOT_PN}/${ROOT_PN}_v${PV}.source.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${ROOT_PN}-${PV}"
+fi
+
+inherit eutils multilib virtualx
+
+DESCRIPTION="Documentation for ROOT Data Analysis Framework"
+HOMEPAGE="http://root.cern.ch/drupal"
+SRC_URI="${SRC_URI}
+ math? (
+ http://tmva.sourceforge.net/docu/TMVAUsersGuide.pdf -> TMVAUsersGuide-v${TMVA_DOC_PV}.pdf
+ http://root.cern.ch/download/doc/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf
+ http://root.cern.ch/drupal/sites/default/files/roofit_quickstart_${ROOFIT_QS_DOC_PV}.pdf )
+ api? (
+ ${HOMEPAGE}/sites/default/files/images/root6-banner.jpg
+ ${HOMEPAGE}/sites/all/themes/newsflash/images/info.png )"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="api +math +metric http"
+
+VIRTUALX_REQUIRED="api"
+
+DEPEND="
+ app-text/pandoc
+ app-text/texlive
+ dev-haskell/pandoc-citeproc[bibutils]
+ virtual/pkgconfig
+ api? (
+ media-fonts/dejavu
+ ~sci-physics/root-${PV}[X,graphviz,opengl]
+ )"
+RDEPEND=""
+
+DOC_DIR="/usr/share/doc/${ROOT_PN}-${PV}"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ # we need to force sci-physics/root checkout here
+ git-r3_checkout "${EGIT_REPO_URI}" "${WORKDIR}/${P}" "sci-physics/root/0"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-6.00.01-makehtml.patch" \
+ "${FILESDIR}/${PN}-6.02.05-jsroot.patch"
+
+ # prefixify the configure script
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ configure || die "prefixify configure failed"
+}
+
+src_configure() {
+ # we need only to setup paths here, html docs doesn't depend on USE flags
+ if use api; then
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --etcdir="${EPREFIX}/etc/root" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)/${PN}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --tutdir="${EPREFIX}/usr/share/doc/${PF}/examples/tutorials" \
+ --testdir="${EPREFIX}/usr/share/doc/${PF}/examples/tests" \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --with-sys-iconpath="${EPREFIX}/usr/share/pixmaps" \
+ --nohowto
+ fi
+}
+
+src_compile() {
+ pdf_target=( primer users-guide )
+ local pdf_size=pdfa4
+ use metric || pdf_size=pdfletter
+ use math && pdf_target+=( minuit2 spectrum )
+ use http && pdf_target+=( HttpServer JSROOT )
+
+ local i
+ for (( i=0; i<${#pdf_target[@]}; i++ )); do
+ emake -C documentation/"${pdf_target[i]}" "${pdf_size}"
+ done
+
+ if use api; then
+ # video drivers may want to access hardware devices
+ cards=$(echo -n /dev/dri/card* /dev/ati/card* /dev/nvidiactl* | sed 's/ /:/g')
+ [[ -n "${cards}" ]] && addpredict "${cards}"
+
+ ROOTSYS="${S}" Xemake html
+ # if root.exe crashes, return code will be 0 due to gdb attach,
+ # so we need to check if last html file was generated;
+ # this check is volatile and can't catch crash on the last file.
+ [[ -f htmldoc/WindowAttributes_t.html ]] || die "html doc generation crashed"
+ fi
+}
+
+src_install() {
+ insinto "${DOC_DIR}"
+
+ local i
+ for (( i=0; i<${#pdf_target[@]}; i++ )); do
+ doins documentation/"${pdf_target[i]}"/*.pdf
+ done
+ unset pdf_target
+
+ use math && doins \
+ "${DISTDIR}/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf" \
+ "${DISTDIR}/roofit_quickstart_${ROOFIT_QS_DOC_PV}.pdf" \
+ "${DISTDIR}/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf"
+
+ if use api; then
+ # Install offline replacements for online messages
+ cp "${DISTDIR}"/{root6-banner.jpg,info.png} htmldoc/ || die "cp failed"
+ # too large data to copy
+ dodir "${DOC_DIR}/html"
+ mv htmldoc/* "${ED}${DOC_DIR}/html/" || die
+ docompress -x ${DOC_DIR}/html
+ fi
+}