summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-15 14:21:17 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-15 14:21:17 +0000
commit9b81effe8e5b004d091e267fdb2fc03467817c55 (patch)
treed9030b437dc1d0889be9650c388d79d721dc32ca /app-doc/psmark/psmark-2.1.ebuild
parentEAPI5 (diff)
downloadgentoo-2-9b81effe8e5b004d091e267fdb2fc03467817c55.tar.gz
gentoo-2-9b81effe8e5b004d091e267fdb2fc03467817c55.tar.bz2
gentoo-2-9b81effe8e5b004d091e267fdb2fc03467817c55.zip
EAPI5. Keyword ~amd64.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-doc/psmark/psmark-2.1.ebuild')
-rw-r--r--app-doc/psmark/psmark-2.1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-doc/psmark/psmark-2.1.ebuild b/app-doc/psmark/psmark-2.1.ebuild
index 6bcba2e6f663..b2d838280c6d 100644
--- a/app-doc/psmark/psmark-2.1.ebuild
+++ b/app-doc/psmark/psmark-2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/psmark-2.1.ebuild,v 1.4 2014/08/10 10:58:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/psmark/psmark-2.1.ebuild,v 1.5 2015/01/15 14:21:17 mrueg Exp $
+
+EAPI=5
inherit eutils toolchain-funcs
@@ -8,31 +10,26 @@ MY_PN=${PN}-v
MY_P=${MY_PN}${PV}
S=${WORKDIR}/${PN}
-IUSE=""
DESCRIPTION="Prints watermark-like text on any PostScript document"
HOMEPAGE="http://www.antitachyon.com/Content/10_Produkte/50_Utilities/psmark/"
SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
+IUSE=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
+KEYWORDS="~amd64 ~x86"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-string.patch
- epatch "${FILESDIR}"/${P}-Makefile-QA.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-string.patch\
+ "${FILESDIR}"/${P}-Makefile-QA.patch
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
- dobin psmark || die "dobin failed"
- doman psmark.1 || die "doman failed"
- dodoc README CHANGELOG || die "dodoc failed"
+ dobin psmark
+ doman psmark.1
+ dodoc README CHANGELOG
}