summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-16 15:05:52 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-16 15:05:52 +0000
commitfe42519382880595129ac51543bfb364f1bdf749 (patch)
treee92463717ab4560773bbfdf83a2e680141683ae6 /app-dicts
parentVersion bump for Gnome 3.6. (diff)
downloadgentoo-2-fe42519382880595129ac51543bfb364f1bdf749.tar.gz
gentoo-2-fe42519382880595129ac51543bfb364f1bdf749.tar.bz2
gentoo-2-fe42519382880595129ac51543bfb364f1bdf749.zip
Version bump for Gnome 3.6.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/ChangeLog8
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/app-dicts/gnome-dictionary/ChangeLog b/app-dicts/gnome-dictionary/ChangeLog
index 0410bb42b339..356deb7b7ec3 100644
--- a/app-dicts/gnome-dictionary/ChangeLog
+++ b/app-dicts/gnome-dictionary/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/gnome-dictionary
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gnome-dictionary/ChangeLog,v 1.1 2012/05/05 07:24:57 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gnome-dictionary/ChangeLog,v 1.2 2012/12/16 15:05:52 eva Exp $
+
+*gnome-dictionary-3.6.0 (16 Dec 2012)
+
+ 16 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-dictionary-3.6.0.ebuild:
+ Version bump for Gnome 3.6.
*gnome-dictionary-3.4.0 (05 May 2012)
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild
new file mode 100644
index 000000000000..b399fa8a6fa3
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild,v 1.1 2012/12/16 15:05:52 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Dictionary utility for GNOME 3"
+HOMEPAGE="https://live.gnome.org/GnomeUtils"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+SLOT="0"
+IUSE="ipv6"
+if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ x11-libs/cairo
+ >=x11-libs/gtk+-3:3
+ x11-libs/pango
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ app-text/yelp-tools
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+fi
+
+src_configure() {
+ DOCS="AUTHORS NEWS README TODO"
+ G2CONF="${G2CONF} $(use_enable ipv6)"
+ [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
+ gnome2_src_configure
+}