summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-14 12:09:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-14 12:09:49 +0000
commitf155dec8709e4f6f5903b28843ce752704b5e785 (patch)
treeb3b3f0a7fb20ba354bac6eb72139f3dea51b4010 /app-crypt
parentStable for x86, wrt bug #429216 (diff)
downloadgentoo-2-f155dec8709e4f6f5903b28843ce752704b5e785.tar.gz
gentoo-2-f155dec8709e4f6f5903b28843ce752704b5e785.tar.bz2
gentoo-2-f155dec8709e4f6f5903b28843ce752704b5e785.zip
Version bump, I was testing if it had fixed the issue from bug#400751 but it did not. Commiting as it works perfect otherwise.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/pinentry-0.8.2.ebuild99
2 files changed, 106 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 064f4d2b420f..bb8f5f5a1658 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/pinentry
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.123 2012/07/03 19:38:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.124 2012/08/14 12:09:49 scarabeus Exp $
+
+*pinentry-0.8.2 (14 Aug 2012)
+
+ 14 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> +pinentry-0.8.2.ebuild:
+ Version bump, I was testing if it had fixed the issue from bug#400751 but it
+ did not. Commiting as it works perfect otherwise.
03 Jul 2012; Jeroen Roovers <jer@gentoo.org> pinentry-0.8.1.ebuild:
Stable for HPPA (bug #421593).
diff --git a/app-crypt/pinentry/pinentry-0.8.2.ebuild b/app-crypt/pinentry/pinentry-0.8.2.ebuild
new file mode 100644
index 000000000000..566a420db1e1
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.8.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.8.2.ebuild,v 1.1 2012/08/14 12:09:49 scarabeus Exp $
+
+EAPI=3
+
+inherit multilib eutils flag-o-matic
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk ncurses qt4 caps static"
+
+RDEPEND="app-admin/eselect-pinentry
+ static? ( >=sys-libs/ncurses-5.7-r5[static-libs] )
+ !static? (
+ gtk? ( x11-libs/gtk+:2 )
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( >=x11-libs/qt-gui-4.4.1 )
+ !gtk? ( !qt4? ( !ncurses? ( sys-libs/ncurses ) ) )
+ )
+ caps? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}
+ !static? (
+ gtk? ( virtual/pkgconfig )
+ qt4? ( virtual/pkgconfig )
+ )"
+
+pkg_setup() {
+ use static && append-ldflags -static
+
+ if use static && { use gtk || use qt4; }; then
+ ewarn
+ ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk and qt4 USE flags."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ if use qt4; then
+ local file
+ for file in qt4/*.moc; do
+ "${EPREFIX}"/usr/bin/moc ${file/.moc/.h} > ${file} || die
+ done
+ fi
+}
+
+src_configure() {
+ local myconf=""
+
+ if ! { use qt4 || use gtk || use ncurses; }
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ elif use static
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses --disable-pinentry-gtk2 --disable-pinentry-qt4"
+ fi
+
+ # Issues finding qt on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-maintainer-mode \
+ --disable-pinentry-gtk \
+ $(use_enable gtk pinentry-gtk2) \
+ --disable-pinentry-qt \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_enable qt4 pinentry-qt4) \
+ $(use_with caps libcap) \
+ --without-x \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ rm -f "${ED}"/usr/bin/pinentry || die
+}
+
+pkg_postinst() {
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}