summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-17 19:51:42 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-17 19:51:42 +0000
commitd57880b1082293f84a514473a66bc688d952ad6b (patch)
treec04c4228b97694906d6f7c427f5ff48368103353 /app-crypt
parentInitial commit (diff)
downloadgentoo-2-d57880b1082293f84a514473a66bc688d952ad6b.tar.gz
gentoo-2-d57880b1082293f84a514473a66bc688d952ad6b.tar.bz2
gentoo-2-d57880b1082293f84a514473a66bc688d952ad6b.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gcr/ChangeLog7
-rw-r--r--app-crypt/gcr/gcr-3.8.1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index 96b718cc63b6..de61eb0cb68a 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.18 2013/04/07 22:19:14 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.19 2013/04/17 19:51:42 pacho Exp $
+
+*gcr-3.8.1 (17 Apr 2013)
+
+ 17 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gcr-3.8.1.ebuild:
+ Version bump
07 Apr 2013; Gilles Dartiguelongue <eva@gentoo.org> gcr-3.8.0.ebuild:
Apply team policy.
diff --git a/app-crypt/gcr/gcr-3.8.1.ebuild b/app-crypt/gcr/gcr-3.8.1.ebuild
new file mode 100644
index 000000000000..51f6786b8737
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.8.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.8.1.ebuild,v 1.1 2013/04/17 19:51:42 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://developer.gnome.org/gcr/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-3
+IUSE="debug gtk +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=app-crypt/gnupg-2
+ >=app-crypt/p11-kit-0.6
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libgcrypt-1.2.2:=
+ >=dev-libs/libtasn1-1:=
+ >=sys-apps/dbus-1
+ gtk? ( >=x11-libs/gtk+-3:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-keyring-3.3
+"
+# gcr was part of gnome-keyring until 3.3
+DEPEND="${COMMON_DEPEND}
+ dev-libs/gobject-introspection-common
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+
+src_prepare() {
+ # Disable stupid flag changes
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_with gtk) \
+ $(use_enable introspection) \
+ $(usex debug --enable-debug=yes --enable-debug=default) \
+ --disable-update-icon-cache \
+ --disable-update-mime
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}