summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-04-02 11:09:42 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-04-02 11:09:42 +0000
commit428bd6bf540ff9e0f1df027f96fa17f7eb077c74 (patch)
tree5d3170a25813622a8d02172f62464f12e4768d7c /app-crypt
parentAdd ~ia64 keyword wrt bug 171580 (diff)
downloadgentoo-2-428bd6bf540ff9e0f1df027f96fa17f7eb077c74.tar.gz
gentoo-2-428bd6bf540ff9e0f1df027f96fa17f7eb077c74.tar.bz2
gentoo-2-428bd6bf540ff9e0f1df027f96fa17f7eb077c74.zip
Version bump, bug#173047
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/ChangeLog10
-rw-r--r--app-crypt/xca/files/digest-xca-0.6.03
-rw-r--r--app-crypt/xca/files/xca-0.6.0-build.patch25
-rw-r--r--app-crypt/xca/xca-0.6.0.ebuild56
4 files changed, 92 insertions, 2 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 09af12c46704..84065df19ac3 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/xca
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.10 2006/10/28 22:50:34 alonbl Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.11 2007/04/02 11:09:42 alonbl Exp $
+
+*xca-0.6.0 (02 Apr 2007)
+
+ 02 Apr 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/xca-0.6.0-build.patch, +xca-0.6.0.ebuild:
+ Version bump, bug#173047
28 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org> +files/xca-0.5.1-db.patch,
xca-0.5.1-r1.ebuild:
diff --git a/app-crypt/xca/files/digest-xca-0.6.0 b/app-crypt/xca/files/digest-xca-0.6.0
new file mode 100644
index 000000000000..3dcb0396ba51
--- /dev/null
+++ b/app-crypt/xca/files/digest-xca-0.6.0
@@ -0,0 +1,3 @@
+MD5 9f683408a35630217e4f5250f1d14ff4 xca-0.6.0.tar.gz 261479
+RMD160 cea0ca3eeefe2cf015b9be1edcb11e4f8c868490 xca-0.6.0.tar.gz 261479
+SHA256 523e406a4e94e006aa72ae53f24e8ccf9b55b348e1695f27abf2abc23ff74077 xca-0.6.0.tar.gz 261479
diff --git a/app-crypt/xca/files/xca-0.6.0-build.patch b/app-crypt/xca/files/xca-0.6.0-build.patch
new file mode 100644
index 000000000000..eec44664f2ad
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.6.0-build.patch
@@ -0,0 +1,25 @@
+--- xca-0.6.0/configure 2007-03-16 21:34:51.000000000 +0200
++++ xca-0.6.0.new/configure 2007-04-02 13:48:17.000000000 +0300
+@@ -103,17 +103,19 @@ search_includes() {
+ # check for libs
+ search_lib() {
+ for dir in ${DIRS}; do
++for subdir in "" ${subdirs}; do
+ for dbn in $@; do
+ for suffix in so dylib obj a; do
+ for lib in lib out; do
+- if test -r "${dir}/${lib}/lib${dbn}.${suffix}"; then
+- add_lib "${dir}/${lib}" "${dbn}" "${suffix}"
+- echo "Found: lib${dbn}.${suffix} at ${dir}/${lib}"
++ if test -r "${dir}/${lib}/${subdir}/lib${dbn}.${suffix}"; then
++ add_lib "${dir}/${lib}/${subdir}" "${dbn}" "${suffix}"
++ echo "Found: lib${dbn}.${suffix} at ${dir}/${lib}/${subdir}"
+ return 0
+ fi
+ done
+ done
+ done
++done
+ done
+ return 1
+ }
diff --git a/app-crypt/xca/xca-0.6.0.ebuild b/app-crypt/xca/xca-0.6.0.ebuild
new file mode 100644
index 000000000000..4411058607c7
--- /dev/null
+++ b/app-crypt/xca/xca-0.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.6.0.ebuild,v 1.1 2007/04/02 11:09:42 alonbl Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.8
+ =x11-libs/qt-4*"
+
+pkg_setup() {
+ # Upstream:
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1692800&group_id=62274&atid=500028
+ if has_version ">=x11-libs/qt-4.2.2" ; then
+ if ! built_with_use x11-libs/qt qt3support ; then
+ eerror ">=qt4.2.2 requires qt3support"
+ die "rebuild >=x11-libs/qt-4.2.2 with the qt3support USE flag"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream:
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1692798&group_id=62274&atid=500027
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ QTDIR=/usr \
+ STRIP="true" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ prefix=/usr \
+ ./configure || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install
+
+ dodoc README CREDITS AUTHORS COPYRIGHT
+
+ insinto /etc/xca
+ doins misc/*.txt
+}