summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-03-21 21:51:45 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-03-21 21:51:45 +0000
commit7a2164d2097c23861872dbdd9f3d5eb4f23a141b (patch)
treeca39207a309ab8c1515acfcd4d32a5413768235d /app-crypt/rotix
parentAll stable (diff)
downloadgentoo-2-7a2164d2097c23861872dbdd9f3d5eb4f23a141b.tar.gz
gentoo-2-7a2164d2097c23861872dbdd9f3d5eb4f23a141b.tar.bz2
gentoo-2-7a2164d2097c23861872dbdd9f3d5eb4f23a141b.zip
Add patch to not strip binary and respect CFLAGS
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-crypt/rotix')
-rw-r--r--app-crypt/rotix/ChangeLog10
-rw-r--r--app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch23
-rw-r--r--app-crypt/rotix/rotix-0.83.ebuild14
3 files changed, 41 insertions, 6 deletions
diff --git a/app-crypt/rotix/ChangeLog b/app-crypt/rotix/ChangeLog
index c7b1ac9d68f4..deb6a51dcd56 100644
--- a/app-crypt/rotix/ChangeLog
+++ b/app-crypt/rotix/ChangeLog
@@ -1,9 +1,10 @@
# ChangeLog for app-crypt/rotix
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.8 2007/02/08 21:23:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.9 2007/03/21 21:51:45 armin76 Exp $
- 10 Dec 2003; Jon Portnoy <avenj@gentoo.org> rotix-0.83.ebuild :
- AMD64 keyword.
+ 21 Mar 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/0.83-respect-CFLAGS-and-dont-strip.patch, rotix-0.83.ebuild:
+ Add patch to not strip binary and respect CFLAGS
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
@@ -11,6 +12,9 @@
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> rotix-0.83.ebuild:
Masked rotix-0.83.ebuild stable for ppc
+ 10 Dec 2003; Jon Portnoy <avenj@gentoo.org> rotix-0.83.ebuild:
+ AMD64 keyword.
+
*rotix-0.83 (20 Dec 2002)
20 Dec 2002; Jon Portnoy <avenj@gentoo.org> rotix-0.83.ebuild :
diff --git a/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
new file mode 100644
index 000000000000..85498d2e03af
--- /dev/null
+++ b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
@@ -0,0 +1,23 @@
+--- Makefile.orig 2007-03-21 22:43:39.000000000 +0100
++++ Makefile 2007-03-21 22:44:16.000000000 +0100
+@@ -24,8 +24,6 @@
+
+ ifdef DEBUG
+ CFLAGS += -g3
+-else
+-CFLAGS += -O3
+ endif
+
+ ifdef I18N
+@@ -40,11 +38,6 @@
+
+ rotix : rot.o help.o rotix.o
+ $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
+-ifdef STRIP
+-ifndef DEBUG
+- $(STRIP) rotix
+-endif
+-endif
+
+ ifdef I18N
+ CFLAGS += -D I18N=1
diff --git a/app-crypt/rotix/rotix-0.83.ebuild b/app-crypt/rotix/rotix-0.83.ebuild
index 31acd28f35fe..788117dadda3 100644
--- a/app-crypt/rotix/rotix-0.83.ebuild
+++ b/app-crypt/rotix/rotix-0.83.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.11 2005/01/01 12:38:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.12 2007/03/21 21:51:45 armin76 Exp $
+
+inherit eutils
DESCRIPTION="Rotix allows you to generate rotational obfuscations."
HOMEPAGE="http://elektron.its.tudelft.nl/~hemmin98/rotix.html"
@@ -13,6 +15,12 @@ IUSE="nls"
RDEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-respect-CFLAGS-and-dont-strip.patch
+}
+
src_compile() {
local myconf
use nls && myconf="--i18n=1"
@@ -21,5 +29,5 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR=${D} install || die
}