summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-14 16:44:17 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-14 16:44:17 +0000
commit7d8f35b48a1cd75c214318abc5635480f04bba1a (patch)
tree0267cee962d222401ef6f8464c0137dbb5cdb6d2 /app-crypt/qca/qca-2.0.0-r2.ebuild
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-7d8f35b48a1cd75c214318abc5635480f04bba1a.tar.gz
gentoo-2-7d8f35b48a1cd75c214318abc5635480f04bba1a.tar.bz2
gentoo-2-7d8f35b48a1cd75c214318abc5635480f04bba1a.zip
Add ~amd64-linux/~x86-linux; drop old versions
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-crypt/qca/qca-2.0.0-r2.ebuild')
-rw-r--r--app-crypt/qca/qca-2.0.0-r2.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-crypt/qca/qca-2.0.0-r2.ebuild b/app-crypt/qca/qca-2.0.0-r2.ebuild
deleted file mode 100644
index 808de7ea665c..000000000000
--- a/app-crypt/qca/qca-2.0.0-r2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.0-r2.ebuild,v 1.19 2009/10/05 19:08:48 ayoy Exp $
-
-EAPI="2"
-
-inherit eutils multilib qt4
-
-DESCRIPTION="Qt Cryptographic Architecture (QCA)"
-HOMEPAGE="http://delta.affinix.com/qca/"
-SRC_URI="http://delta.affinix.com/download/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug doc examples"
-RESTRICT="test"
-
-DEPEND="!<app-crypt/qca-1.0-r3
- x11-libs/qt-core:4[debug?]"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-debug-same-pkgconfig-file.patch" )
-
-src_configure() {
- _libdir=$(get_libdir)
- local myconf
- if use debug; then
- myconf="--debug"
- else
- myconf="--release"
- fi
-
- # Multilib fix.
- sed -e "/pcfiles.path/s:lib:${_libdir}:" \
- -i "${S}"/configure || die "Multilib fix failed."
-
- ./configure \
- --prefix=/usr \
- --qtdir=/usr \
- --includedir="/usr/include/qca2" \
- --libdir="/usr/${_libdir}/qca2" \
- --no-separate-debug-info \
- --disable-tests \
- ${myconf} \
- || die "configure failed"
-
- eqmake4 ${PN}.pro
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc README TODO || die "dodoc failed."
-
- cat <<-EOF > "${WORKDIR}"/44qca2
- LDPATH=/usr/${_libdir}/qca2
- EOF
- doenvd "${WORKDIR}"/44qca2
-
- if use doc; then
- dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/
- doins -r "${S}"/examples || die "Failed to install examples"
- fi
-}