summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-22 04:21:38 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-22 04:21:38 +0000
commit4b893538916cdf5326bfde9d52eba902078c82a0 (patch)
tree4838458a9c1eebeffd14eea30c1fc37be0bfd4f8 /app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
parentadd forgotten patches (diff)
downloadgentoo-2-4b893538916cdf5326bfde9d52eba902078c82a0.tar.gz
gentoo-2-4b893538916cdf5326bfde9d52eba902078c82a0.tar.bz2
gentoo-2-4b893538916cdf5326bfde9d52eba902078c82a0.zip
Keyword ~amd64-linux/~x86-linux, prefixify; remove old
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild')
-rw-r--r--app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
deleted file mode 100644
index b2b4133cb5a1..000000000000
--- a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild,v 1.15 2009/12/29 18:11:28 armin76 Exp $
-
-inherit base eutils qt4
-
-MY_P="${P/_/-}"
-QCA_VER="${PV%.*}"
-
-DESCRIPTION="TLS, S/MIME, PKCS#12, crypto algorithms plugin for QCA"
-HOMEPAGE="http://delta.affinix.com/qca/"
-SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND=">=app-crypt/qca-${QCA_VER}
- >=dev-libs/openssl-0.9.6"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${PN}-openssl-0.9.8i.patch" )
-
-pkg_setup() {
- if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
- echo
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while qca is built without this flag. It will not work."
- echo
- eerror "Possible solutions to this problem are:"
- eerror "a) install ${PN} without debug USE flag"
- eerror "b) re-emerge qca with debug USE flag"
- echo
- die "can't emerge ${PN} with debug USE flag"
- fi
-}
-
-src_compile() {
- # cannot use econf because of non-standard configure script
- ./configure \
- --qtdir=/usr \
- $(use debug && echo "--debug" || echo "--release") \
- --no-separate-debug-info \
- || die "configure failed"
-
- eqmake4 ${PN}.pro
- sed -i -e '/strip/d' Makefile || die "sed failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
-}