summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-19 14:01:51 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-19 14:01:51 +0000
commitdaa75e62a26a6af01ec8e4aed7f12b37244e0745 (patch)
tree116a828abe0a417499b15000c95a993ab456f224 /app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
parentRemove old version. (diff)
downloadgentoo-2-daa75e62a26a6af01ec8e4aed7f12b37244e0745.tar.gz
gentoo-2-daa75e62a26a6af01ec8e4aed7f12b37244e0745.tar.bz2
gentoo-2-daa75e62a26a6af01ec8e4aed7f12b37244e0745.zip
Migrated to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild')
-rw-r--r--app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild b/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
index 1dbc984246df..adf0031fc7c4 100644
--- a/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
+++ b/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild,v 1.8 2009/07/21 16:48:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild,v 1.9 2009/08/19 14:01:51 betelgeuse Exp $
+
+EAPI="2"
inherit eutils qt4
@@ -16,27 +18,13 @@ SLOT="2"
KEYWORDS="alpha amd64 ia64 ~ppc64 sparc x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=app-crypt/qca-${QCA_VER}
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
dev-libs/cyrus-sasl"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
- echo
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while qca is built without this flag. It will not work."
- echo
- eerror "Possible solutions to this problem are:"
- eerror "a) install ${PN} without debug USE flag"
- eerror "b) re-emerge qca with debug USE flag"
- echo
- die "can't emerge ${PN} with debug USE flag"
- fi
-}
-
-src_compile() {
+src_configure() {
# cannot use econf because of non-standard configure script
./configure \
--qtdir=/usr \
@@ -45,7 +33,6 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
- emake || die "make failed"
}
src_install() {