summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-26 13:24:46 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-26 13:24:46 +0000
commitb942c8ce7c359545271d90a7b84c1a0b5973fe05 (patch)
tree98999f2126b23926f51ef63c79b42300ac5512aa /app-crypt/libu2f-host
parentUpdate to use built-in EAPI functionality (diff)
downloadgentoo-2-b942c8ce7c359545271d90a7b84c1a0b5973fe05.tar.gz
gentoo-2-b942c8ce7c359545271d90a7b84c1a0b5973fe05.tar.bz2
gentoo-2-b942c8ce7c359545271d90a7b84c1a0b5973fe05.zip
app-crypt/libu2f-host: Version Bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-crypt/libu2f-host')
-rw-r--r--app-crypt/libu2f-host/ChangeLog7
-rw-r--r--app-crypt/libu2f-host/libu2f-host-0.0.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-crypt/libu2f-host/ChangeLog b/app-crypt/libu2f-host/ChangeLog
index 07c79dabf068..a4482dadb2de 100644
--- a/app-crypt/libu2f-host/ChangeLog
+++ b/app-crypt/libu2f-host/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/libu2f-host
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/ChangeLog,v 1.8 2014/11/10 17:01:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/ChangeLog,v 1.9 2014/12/26 13:24:46 jlec Exp $
+
+*libu2f-host-0.0.2 (26 Dec 2014)
+
+ 26 Dec 2014; Justin Lecher <jlec@gentoo.org> +libu2f-host-0.0.2.ebuild:
+ Version Bump
*libu2f-host-0.0.1-r2 (10 Nov 2014)
diff --git a/app-crypt/libu2f-host/libu2f-host-0.0.2.ebuild b/app-crypt/libu2f-host/libu2f-host-0.0.2.ebuild
new file mode 100644
index 000000000000..1a45a2abe68e
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-0.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/libu2f-host-0.0.2.ebuild,v 1.1 2014/12/26 13:24:46 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils linux-info udev
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="
+ dev-libs/hidapi
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ sed -e 's:TAG+="uaccess":MODE="0664", GROUP="plugdev":g' \
+ 70-u2f.rules > 70-u2f-udev.rules || die
+}
+
+src_configure() {
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ if use systemd; then
+ udev_dorules 70-u2f.rules
+ else
+ udev_newrules 70-u2f-udev.rules 70-u2f.rules
+ fi
+ fi
+}