summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-11-05 16:57:17 +0000
committerRick Farina <zerochaos@gentoo.org>2014-11-05 16:57:17 +0000
commit034087eecd8291e2abacde7a6669a53b84d8e7e2 (patch)
treefd3cc8644950f5eecb7d0342befa8ddc272e6f3e /app-crypt/libu2f-host
parentRemove ineffective sed script. (diff)
downloadgentoo-2-034087eecd8291e2abacde7a6669a53b84d8e7e2.tar.gz
gentoo-2-034087eecd8291e2abacde7a6669a53b84d8e7e2.tar.bz2
gentoo-2-034087eecd8291e2abacde7a6669a53b84d8e7e2.zip
bump per bug #528280, adding USE=static-libs to disable building static-libs
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-crypt/libu2f-host')
-rw-r--r--app-crypt/libu2f-host/ChangeLog7
-rw-r--r--app-crypt/libu2f-host/libu2f-host-0.0.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-crypt/libu2f-host/ChangeLog b/app-crypt/libu2f-host/ChangeLog
index e18b932552fb..1dd0c1b8bea6 100644
--- a/app-crypt/libu2f-host/ChangeLog
+++ b/app-crypt/libu2f-host/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/libu2f-host
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/ChangeLog,v 1.5 2014/10/25 17:36:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/ChangeLog,v 1.6 2014/11/05 16:57:17 zerochaos Exp $
+
+*libu2f-host-0.0.1 (05 Nov 2014)
+
+ 05 Nov 2014; Rick Farina <zerochaos@gentoo.org> +libu2f-host-0.0.1.ebuild:
+ bump per bug #528280, adding USE=static-libs to disable building static-libs
25 Oct 2014; Diego E. Pettenò <flameeyes@gentoo.org>
libu2f-host-0.0-r1.ebuild:
diff --git a/app-crypt/libu2f-host/libu2f-host-0.0.1.ebuild b/app-crypt/libu2f-host/libu2f-host-0.0.1.ebuild
new file mode 100644
index 000000000000..5d8557174b92
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-0.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libu2f-host/libu2f-host-0.0.1.ebuild,v 1.1 2014/11/05 16:57:17 zerochaos Exp $
+
+EAPI=5
+
+inherit autotools-utils linux-info udev
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="dev-libs/hidapi
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+src_prepare() {
+ autotools-utils_src_prepare
+ sed -i -e 's:|\([^0]\):|0\1:g' 70-u2f.rules || die
+
+ sed -e 's:GROUP="plugdev":TAG+="uaccess":g' 70-u2f.rules > 70-u2f-systemd.rules || die
+}
+
+src_configure() {
+ autotools-utils_src_configure
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ if use systemd; then
+ udev_newrules 70-u2f-systemd.rules 70-u2f.rules
+ else
+ udev_dorules 70-u2f.rules
+ fi
+ fi
+}