summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-10-19 14:32:35 +0000
committerPeter Volkov <pva@gentoo.org>2010-10-19 14:32:35 +0000
commitf277a3591320e7f2badaef27b8fc9aa1268278fa (patch)
treeb8221f7e83037b0b7b8713c174aa4290a7765879 /app-cdr
parentVersion bump. (diff)
downloadgentoo-2-f277a3591320e7f2badaef27b8fc9aa1268278fa.tar.gz
gentoo-2-f277a3591320e7f2badaef27b8fc9aa1268278fa.tar.bz2
gentoo-2-f277a3591320e7f2badaef27b8fc9aa1268278fa.zip
Version bump.
(Portage version: 2.1.9.18/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemud/ChangeLog7
-rw-r--r--app-cdr/cdemud/cdemud-1.3.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-cdr/cdemud/ChangeLog b/app-cdr/cdemud/ChangeLog
index 76b867258a1c..9b7a75157982 100644
--- a/app-cdr/cdemud/ChangeLog
+++ b/app-cdr/cdemud/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-cdr/cdemud
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.14 2010/02/09 06:32:07 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.15 2010/10/19 14:32:35 pva Exp $
+
+*cdemud-1.3.0 (19 Oct 2010)
+
+ 19 Oct 2010; Peter Volkov <pva@gentoo.org> +cdemud-1.3.0.ebuild:
+ Version bump.
09 Feb 2010; Peter Volkov <pva@gentoo.org> files/cdemud.init.d-1.1.0:
Remove bashism from init script, bug #303847 by Michał Górny
diff --git a/app-cdr/cdemud/cdemud-1.3.0.ebuild b/app-cdr/cdemud/cdemud-1.3.0.ebuild
new file mode 100644
index 000000000000..6c2b8e7af70d
--- /dev/null
+++ b/app-cdr/cdemud/cdemud-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/cdemud-1.3.0.ebuild,v 1.1 2010/10/19 14:32:35 pva Exp $
+
+EAPI="2"
+
+DESCRIPTION="Daemon of the cdemu cd image mounting suite"
+HOMEPAGE="http://www.cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-daemon-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio"
+
+RDEPEND=">dev-libs/dbus-glib-0.6
+ >=dev-libs/libdaemon-0.10
+ >=dev-libs/libmirage-1.3.0
+ media-libs/libao[alsa?,pulseaudio?]
+ >=sys-fs/vhba-20101015
+ >=sys-fs/sysfsutils-2.1.0"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/cdemu-daemon-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die
+
+ newconfd "${FILESDIR}/${PN}.conf.d-1.1.0" ${PN} || die
+ newinitd "${FILESDIR}/${PN}.init.d-1.1.0" ${PN} || die
+}
+
+pkg_postinst() {
+ elog "Either cdemu group users can start"
+ elog "their own daemons or you can start"
+ elog "a systembus style daemon, adding"
+ elog "${PN} to the default runlevel by"
+ elog " # rc-update add ${PN} default"
+ elog "as root. Systembus style daemons can be configured"
+ elog "in /etc/conf.d/{PN}"
+}