summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-16 19:36:30 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-16 19:36:30 +0000
commitebfdda94660ac583d7aa1d2373fe9eaf4bc8e789 (patch)
treebcda7ada3f91da1375cfefdcb149f38dd026b36d /app-cdr
parentmark stable (diff)
downloadgentoo-2-ebfdda94660ac583d7aa1d2373fe9eaf4bc8e789.tar.gz
gentoo-2-ebfdda94660ac583d7aa1d2373fe9eaf4bc8e789.tar.bz2
gentoo-2-ebfdda94660ac583d7aa1d2373fe9eaf4bc8e789.zip
New revision to fix dependencies
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/xcdroast/ChangeLog5
-rw-r--r--app-cdr/xcdroast/Manifest7
-rw-r--r--app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r31
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha10-r3.ebuild52
4 files changed, 65 insertions, 0 deletions
diff --git a/app-cdr/xcdroast/ChangeLog b/app-cdr/xcdroast/ChangeLog
index b1b1357c073b..26e8d3e1a52c 100644
--- a/app-cdr/xcdroast/ChangeLog
+++ b/app-cdr/xcdroast/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# /space/gentoo/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.7 2002/06/05 02:39:55 lostlogic Exp
+*xcdroast-0.98_alpha10-r3 (16 May 2003)
+
+ 16 May 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Updated dependencies to allow multiple revisions of cdrtools.
+
*xcdroast-0.98_alpha13 (04 Jan 2003)
02 Apr 2003; Lars Weiler <pylon@gentoo.org> xcdroast-0.98_alpha13.ebuild:
diff --git a/app-cdr/xcdroast/Manifest b/app-cdr/xcdroast/Manifest
new file mode 100644
index 000000000000..ef56335085bf
--- /dev/null
+++ b/app-cdr/xcdroast/Manifest
@@ -0,0 +1,7 @@
+MD5 a5d6b76a9b81ebcefdca8c87204b3451 ChangeLog 2335
+MD5 bc2d3c2e00065a1ef0d61da8abd2acd3 xcdroast-0.98_alpha13.ebuild 1038
+MD5 ab4c8b6688ff4ed83dd173e70caa22d9 xcdroast-0.98_alpha10-r3.ebuild 1905
+MD5 a2d876e1e425b819ba0607e7279b8a12 xcdroast-0.98_alpha10-r2.ebuild 1907
+MD5 7af2b7cea7fca6b0e99338246ba10fd4 files/digest-xcdroast-0.98_alpha10-r2 72
+MD5 fd211bcdb0aa941e5ae0cea66cbbebfe files/digest-xcdroast-0.98_alpha13 73
+MD5 7af2b7cea7fca6b0e99338246ba10fd4 files/digest-xcdroast-0.98_alpha10-r3 72
diff --git a/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r3 b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r3
new file mode 100644
index 000000000000..82d6570be400
--- /dev/null
+++ b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r3
@@ -0,0 +1 @@
+MD5 6f9ffd30c7ba8f067c2f1bddcc83d7d8 xcdroast-0.98alpha10.tar.gz 749736
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha10-r3.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r3.ebuild
new file mode 100644
index 000000000000..1a9c4b6f895a
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha10-r3.ebuild,v 1.1 2003/05/16 19:36:30 aliz Exp $
+
+MY_P="${P/_/}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+SRC_URI="http://www.xcdroast.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://www.xcdroast.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+# WARNING: cdrtools and mkisofs versions hard coded, see below
+DEPEND="=x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ >=media-libs/gdk-pixbuf-0.16.0
+ >=media-libs/giflib-3.0
+ ~app-cdr/cdrtools-1.11.33"
+RDEPEND="~app-cdr/cdrtools-1.11.33"
+
+src_compile() {
+ # NOTE: This will need to be updated to work with future versions of
+ # xcdroast (hardcoded versions). The listed dependencies are part
+ # of the cdrtools package.
+ mv xcdroast.h xcdroast.h.orig
+ sed -e 's|CDRECORD_VERSION "1.10"|CDRECORD_VERSION "1.11a24"|' \
+ -e 's|CDDA2WAV_VERSION "1.10"|CDDA2WAV_VERSION "1.11a24"|' \
+ -e 's|READCD_VERSION "1.10"|READCD_VERSION "1.11a19"|' \
+ -e 's|MKISOFS_VERSION "1.14"|MKISOFS_VERSION "1.15a23"|' \
+ xcdroast.h.orig > xcdroast.h || die
+
+ make PREFIX=/usr CC="gcc ${CFLAGS}" || die
+}
+
+src_install() {
+ make PREFIX=/usr DESTDIR=${D} install || die
+ chown root.wheel ${D}/usr/bin/xcdrgtk
+ dodoc CHANGELOG COPYING DOCUMENTATION FAQ README* TRANSLATION.HOWTO
+
+ # move man pages to /usr/share/man to be LFH compliant
+ mv ${D}/usr/man ${D}/usr/share
+}
+
+pkg_postinst() {
+ einfo "Due to limitations in the xcdroast program, the version of cdrtools"
+ einfo "that it depends on must be hardcoded in the xcdroast program. This"
+ einfo "means you must have a specific version of cdrtools installed if you"
+ einfo "plan to use xcdroast. You may need to 'pin' the version of cdrtools"
+ einfo "in use. (See the portage manual for details)"
+}