summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-03-15 09:45:49 +0000
committerRémi Cardona <remi@gentoo.org>2008-03-15 09:45:49 +0000
commita6339d5e26e796e5987ad0f8806c5d514aa2d9bc (patch)
treec4aad8050fc024beeb501163d8bd510865f48553 /app-cdr
parentStable on ppc wrt bug 211018 (diff)
downloadgentoo-2-a6339d5e26e796e5987ad0f8806c5d514aa2d9bc.tar.gz
gentoo-2-a6339d5e26e796e5987ad0f8806c5d514aa2d9bc.tar.bz2
gentoo-2-a6339d5e26e796e5987ad0f8806c5d514aa2d9bc.zip
app-cdr/cdrdao: fix build failure with libsigc++ 2.2
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdrdao/ChangeLog10
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild69
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch12
3 files changed, 89 insertions, 2 deletions
diff --git a/app-cdr/cdrdao/ChangeLog b/app-cdr/cdrdao/ChangeLog
index 426734f2158e..1e9ea263d049 100644
--- a/app-cdr/cdrdao/ChangeLog
+++ b/app-cdr/cdrdao/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/cdrdao
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/ChangeLog,v 1.105 2007/11/14 19:27:22 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/ChangeLog,v 1.106 2008/03/15 09:45:48 remi Exp $
+
+*cdrdao-1.2.2-r1 (15 Mar 2008)
+
+ 15 Mar 2008; Rémi Cardona <remi@gentoo.org>
+ +files/cdrdao-1.2.2-use-new-sigc++-API.patch, +cdrdao-1.2.2-r1.ebuild:
+ fix build failure with libsigc++ 2.2
14 Nov 2007; Samuli Suominen <drac@gentoo.org> cdrdao-1.2.2.ebuild:
amd64 stable wrt #193991
diff --git a/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..9b3ba8cc417c
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild,v 1.1 2008/03/15 09:45:48 remi Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
+HOMEPAGE="http://cdrdao.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdrdao/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome debug encode pccts"
+RESTRICT="strip"
+
+RDEPEND="encode? ( >=media-sound/lame-3.90 )
+ gnome? ( >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libgnomemm-2.6
+ >=dev-cpp/libgnomecanvasmm-2.6
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libgnomeuimm-2.6
+ media-libs/libao )"
+DEPEND="pccts? ( >=dev-util/pccts-1.33.24-r1 )
+ virtual/cdrtools
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes bug #212530
+ epatch "${FILESDIR}/${PN}-1.2.2-use-new-sigc++-API.patch"
+
+ # FreeBSD needs this patch
+ # I think the correct define should be linux, but this will maintain
+ # the status quo for the time being.
+ # Upstream bug #1596097
+ epatch "${FILESDIR}/${P}"-nonlinux.patch
+
+ # Display better SCSI messages (advise from Bug 43003)
+ cd scsilib/include
+ sed -i -e 's:HAVE_SCANSTACK:NO_FRIGGING_SCANSTACK:g' xmconfig.h
+ sed -i -e 's:HAVE_SCANSTACK:NO_FRIGGING_SCANSTACK:g' mconfig.h
+}
+
+src_compile() {
+ # A few CFLAGS do not work see bug #99998
+ strip-flags
+ append-flags "-fno-inline"
+
+ econf \
+ $(use_enable debug) \
+ $(use_with gnome xdao) \
+ $(use_with encode lame) \
+ $(use_with pccts pcctsbin /usr/bin) \
+ $(use_with pccts pcctsinc /usr/include/pccts) \
+ --disable-dependency-tracking || die "configure failed"
+
+ make || die "could not compile"
+}
+
+src_install() {
+ einstall || die "could not install"
+
+ cd "${S}"
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README*
+}
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch b/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch
new file mode 100644
index 000000000000..12731c0777b0
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch
@@ -0,0 +1,12 @@
+http://cdrdao.cvs.sourceforge.net/cdrdao/cdrdao/xdao/xcdrdao.cc?r1=1.30&r2=1.31&view=patch
+--- xdao/xcdrdao.cc 2007/08/15 14:24:49 1.30
++++ xdao/xcdrdao.cc 2007/09/11 08:58:42 1.31
+@@ -144,7 +144,7 @@
+ installSignalHandler(SIGCHLD, signalHandler);
+
+ // setup periodic GUI updates
+- Glib::signal_timeout().connect(SigC::slot(&guiUpdatePeriodic), 2000);
++ Glib::signal_timeout().connect(sigc::ptr_fun(&guiUpdatePeriodic), 2000);
+
+ installSignalHandler(SIGPIPE, SIG_IGN);
+